HP 42S COMB bug?



#2

I discovered what I think is a bug in my HP 42S.

Suppose you want to figure the number of Combinations of 8 things taken 5 at a time. But you mistakenly enter the arguments in opposite order:

5, ENTER, 8, COMB

You get an "Invalid Data" error message. Fine. So you press X EXCHANGE Y to put them in the right order. The display confirms 8 in the Y register and 5 in the X register. But if you press COMB you still get the "Invalid Data" error!

In fact the calculator seems to get stuck in a mode where ANY inputs to COMB give "Invalid Data" error. Clearing X, the whole stack, power cycling don't get it out of this mode. The only way I've found to get back to normal is to perform some arithmetic.

For example, multiply the 5 in the X register by 1:

1, MULTIPLY, COMB
then gives the correct answer of 56.


Anyone else seen this?


#3

Yes, it is a classic bug. I saw it documented on some
article, perhaps in the Forum.

Peter


#4

Yes, it is a well known bug, and affects COMB and PERM the same way.


#5

Ken, Peter and Andres --

I can't replicate the error you describe on my 1989 HP-42S (serial # 2939S33496). Simply re-executing COMB or PERM throught the PROB menu, after pressing X<>Y following the "Invalid Data" message, gives me the correct answers. Was this error characteristic of late or very early units?


#6

I checked 5 HP42S and only one didn't display the bug. That one was made in the USA in 1988.
The other four made between 1993 to 1999 all displayed the bug. If I had to guess I would say it only occurs in the later models.


#7

I had a 1990 model which I service-exchanged in 1999, and both displayed the bug.


Possibly Related Threads...
Thread Author Replies Views Last Post
  HP Prime graphing bug BruceH 1 522 11-19-2013, 08:14 AM
Last Post: Joe Horn
  HP Prime - another cosmetic bug BruceH 3 650 11-12-2013, 02:18 PM
Last Post: Ken Shaw
  HP Prime Bug bluesun08 19 1,863 10-14-2013, 10:48 PM
Last Post: Han
  HP Prime bug in EDITMAT Han 7 1,024 09-27-2013, 10:15 AM
Last Post: Han
  [HP 39Gii] - Bug report Jean-Michel 1 523 08-28-2013, 10:53 AM
Last Post: Tim Wessman
  Is the HP-35S bug free? Matt Agajanian 22 2,172 07-01-2013, 04:03 PM
Last Post: Andrés C. Rodríguez (Argentina)
  Has anyone reported this bug to HP? Allen L. 4 641 01-10-2013, 07:41 PM
Last Post: Manolo Sobrino
  HP-15C Bug with MATRIX 5 Thomas Klemm 17 1,689 02-04-2012, 05:07 PM
Last Post: Paul Dale
  Another HP-15C LE bug? Benoit Maag 58 3,837 10-03-2011, 05:26 PM
Last Post: Steve Simpkin
  42s questions and 42s vs 35s snaggs 13 1,835 09-19-2011, 02:44 AM
Last Post: snaggs

Forum Jump: