Programming a Clonix Module with Laptop

Was wondering if anyone has tried to use a USB to RS-232 converter connected to a laptop to interface with the programmer for the Clonix-41/NoVRAM modules? If so, what make/model of converter is known to work (i.e., one that has the proper voltages present on the RS-232 side of the converter)? The problem is the voltage output from the laptop serial port is usually ± 3.6v whereas the programmer requires something in the range ± 6v to ± 9v.

Any help/info would be greatly appreciated.


Hi Gary,

Like you I've had no luck in programming a Clonix using my laptop (Compaq EVO N600c). The USB on my laptop is ver. 1.1, I doubt this matters as I suspect the voltage is the problem as you suggested.

A little side note... I recently acquired a new Sony PCV RX54G Desktop. It's a good box but lacks a native RS232 port (all USB). I purchased a USB to RS232 cable expecting it would allow me to program a Clonix... no such luck.

I also own an old ISA based PC in which I have installed one of Christoph Klug's HP-IL interface cards. It has two RS232 ports and no USB ports. Neither of the serial ports seem to drive the PIC programmer so I installed a USB card with hopes the USB to RS232 cable would work in this box. Again, no such luck. Murphy at his best!!!

Like you, I'm hoping someone on this forum can shed some light on the situation as I'm currently without a means to program my Clonix or NoVRAM.

Best, Wilson (Bill)

Edited: 16 Oct 2004, 9:32 a.m.


My desktop (an HP Pavillion 760N) has USB 1.1 but also 2 serial ports.

I just bought a keyboard extension cable (making sure the genders of both ends was correct) and hooked up the PIC programmer to the cable to the serial RS232 port.

Works like a charm.

I have not been able to program it with my Omnibook 3100 laptop. No big deal...probably voltage issues.



It is quite likely that the pic programmer does not really use the serial port but simply directly drives some of the control lines CTS/DTR etc...

This means that it will only work on a "real" serial port...


It works fine with my Omnibook 800 - but of course I realize such a model isn't a "real" laptop in the common sense, instead it's really a much better design (the last from the ground up designed in Corvallis, I'm afraid).

I couldn't get it to work with either the Omnibook 4400, nor with the 6000. That's called progress in PC design, no doubt.

Best, AM


Hi Angel,

you're right regarding the OB 800.

A few years ago I had to work on an interface software

for a REFA related handheld data collecting device,

and to make it work under W2K.

My OB 800CT was the only notebook in the company I worked for

which was able to communicate with the handheld device.

None of the newer OmniBooks (4150B, XE3, ...) was able

to connect to the device via the serial port.

The only drawbacks of the OB 800 are the RAM limitations to 80MB,

and the CPU limitation to the Pentium 166MHz MMX,

so W2K runs too slowly.

If it had at least a 233MHz MMX CPU and expandability

to about 256MB of RAM, I think I'd still use it.

However, I settled for an IBM X31 (1GB RAM:-)




Hi all,

Well, it seems like RS-232 is (almost) dead... long live to USB.

I must admit I didn't suppose that the programmer interface was called to become a major issue... it has happened though, so let's go face it.

Bill, I'm really sorry to know of your troubles, I thought you had managed to (re)-pogram your modules since you didn't mention further problems after I sent your Clonix back.

Chris is more than probably right, RS-232 shouldn't be being used (in that programmer) as a "real" serial inteface, but as a simple "signals & timing generator" controlled by the software. Thus the USB<>RS-232 adapter more likely won't work at all.

Fortunatelly, other chances are... , unfortunatelly (as usual), some more expensive ones. Namely, "real" USB programmer (some $30 - $40); and Parallel port Programmer, just about the same price.

Drawbacks (appart from the price itself):

- They both need an external power supply to operate. Mostly any wall-wart over 12v - 15v DC fits the task.

- IC-Prog does not seem to support USB programmers. This is not a big deal really, since every programmer has its own software and .HEX files, generated during the configuration process, are standard and fully interchangeable.

Anyhow I'm now testing with an external supply for the programming voltage (the "real" problem with laptops) and will inform you along the next week.

Best wishes.



Thanks to all who responded to my original post.

Looks like I'm hosed as the only PC platforms that I use these days are Dell laptops -- one is an Inspiron 8000 and the other is a Latitude D600. Has anyone successfully used either of these models with the Clonix programmer?

As a side note I've been playing 20 questions with Diego prior to purchasing his modules and programmer. He has really been excellent to work with. I just wanted to check things out a little before I spent that kind of money only to realize things wouldn't work.

I would really like to use the Clonix with my -41 but if I can't program the thing then what's the point. Bummer!

Thanks again everybody,


Hi again,

I think I've got good news for you laptop users. It happens that I've just successfully programmed one of my Clonix with a Fujitsu-Siemens Lifebook.

It has been impossible to do so up to now and, sincerely, I had not paid much attention as I had (wrongly) assumed that every Clonix/NOVRAM user have access to a "working" serial port...

I took the dust off the thick 18LF252 Data Sheet to dig into its programming specs and... there it was!!

This little wonder has a "LVICSP"... (I know, I also have to dig a bit deeper to find out what the h**l that meant),
namely, Low Voltage In Circuit Serial Programming.

So, there's no need of such (difficult to reach) +12.5v programming voltages... even more, this is the *default* mode after erasing the whole device... then, why it didn't work at first??

Well, pin nr. 26 (RB5) *must* be at Vdd level... and it's wired into module connector, but to the bottom side of the adapter, thus, no track is there to set this pin at Vdd.

I've made a modified adapter to do the test described above... still need more testing and some help:

Can some/all? of you, with a laptop nearby, check if you can "READ" the contents of a Clonix/NoVRAM? Please include info regarding model of your laptop.

Will keep you informed.

Best wishes.



Hi Bill,

Will you please make a test for me?? If you will, this is the job:

Just take a 100 - 150pF cap. (not a critical value) and place it between pins 3 & 4 (the two in the middle) of the white connector.

Then make a try to see if your laptop is now able to read and verify (do not try to program for now) any Clonix/NoVRAM modules.



P.S. Whomever is willing to make this little mod (and knows how to handle a solder iron) is more than welcomed. Please let me know the results. BTW, by doing this mod you cannot damage anything.


Hi Diego,

I'm currently on a month long holiday in Destin, FL. so cannot do any testing since all my 41 stuff is still in Houston. I'll be more than happy to help solve the USB/RS232 riddle shortly after my return. In the meanwhile I'll keep abreast of the issue via my laptop and dial-up.

Best Regards, Bill


Hi Diego,

No apologies necessary!! As Angel would likely say... "NO WORRIES". Yes, I haven't been able to reprogram either my Clonix or my NoVRAM due to the issues I've outlined. However I've had little need to and really didn't want to take any of your truly valuable time troubleshooting the problem, one which I knew would eventually be resolved once I was able to get my older Sony desktop with the RS232 port back up and running.

Best Regards, Bill


Enjoy your vacation Bill!! ;-))

Drop a line when you get back home, I'd like to trace this problem and find a "general solution", so users can burn their modules regardless the type of PC they are using.

Best wishes.



Hi Diego,
I just tried with my OmniBook 800CT and I was able to read&write from/to both Clonix and NoVRAM modules.

No problems when on power cord, some issues when on battery power (verification fails, sometimes).



Hi Massimo,

Thanks a lot for the feedback.

Have you tried the "capacitor trick"? (explained above) or have you just tried as is?




Hi Diego,

I'll drop you a line shortly after returning and will help resolve the problem in any way I can. And yes, I will enjoy my European style (month long) vacation. It's been a real blast thus far!!!

Best Regards, Bill


Have you tried the "capacitor trick"? (explained above) or have you just tried as is?

Just the vanilla adapter...


Possibly Related Threads…
Thread Author Replies Views Last Post
  HP-41 Clonix&NoV's SW Update. (For the non-Primer's guys out there... :-) Diego Diaz 21 5,765 11-13-2013, 09:00 AM
Last Post: Ángel Martin
  Prime as laptop numeric keypad Jose Gonzalez Divasson 1 1,162 10-31-2013, 02:25 AM
Last Post: debrouxl
  Warning: These are NOT Clonix! Diego Diaz 11 3,144 03-02-2013, 01:15 PM
Last Post: Diego Diaz
  Latest Clonix/NoV's SW update. Diego Diaz 5 2,167 02-15-2013, 12:12 PM
Last Post: Ángel Martin
  [41CL]Updating ROM images with a Clonix Dan Grelinger 14 4,357 02-13-2013, 10:41 AM
Last Post: Ángel Martin
  [Clonix/NOV] NoV-64 backwards compatibility Doug (NYC) 0 997 01-20-2013, 11:21 AM
Last Post: Doug (NYC)
  HP-41 takeover ROM with Clonix-D Sylvain Cote 1 1,096 10-15-2012, 02:37 PM
Last Post: Diego Diaz
  USB-41->NoV-64/Clonix-D compatibility Diego Diaz 5 2,112 06-15-2012, 12:18 AM
Last Post: Les Wright
  OT: cursor randomly jumping aroud on laptop bill platt 6 2,228 03-28-2012, 09:53 AM
Last Post: Mark Storkamp
  Latest update for Clonix & NoV's modules (includes DISASM patch for 41CL) Diego Diaz 9 2,798 01-26-2012, 01:34 PM
Last Post: Geir Isene

Forum Jump: