Help with flashing HP30s

I'm trying to flash my HP30s and failing.

The setup:

* Programming cable (thank you, Gene)
* HP30s hooked to power supply (batteries are expensive)
* Atmel's sam-ba 2.12 on both Windows (vista) and Linux (ubuntu)
* Both hardware serial ports and USB serial adaptors.

None of the four combinations of port type and operating system seem to work. I select the port in sam-ba, select the right chip, and then I either get connection error (windows) or just indefinite wait (linux).

The instructions on the wiki mention sam-ba v2.9, but that's not available any more, and I don't see why that would make a difference.

I have an oscilloscope, a logic analyzer, and stuff like that, if debugging the problem involves using them.





Please use the procedure as specified in the manual - it will work.



Hi John,

"Samba" never worked for me too.
I allways use "mySamba", give it a chance...


Grab the file from this web site here All of this is in the manual, but somehow I was lead to the wrong version of samba my first time too, so use the MySamba program from the link above on a windows 7 machine and you will be fine.

Edited: 2 Sept 2013, 11:04 a.m.


If you by that you mean "erase the calculator first", yes, I did that. AFAICT, I'm using the procedure in the manual.




I did that too. strace() on the process shows that the calculator never responds to the first two commands sent by the flashing program.

I've tried this on two calculators. Any way of testing whether the cable is working properly?


You can mail the calculator to someone with a known good flashing cable. I don't have one, but perhaps you can find someone on the forum who does.


I too was not able to get the flash process to work until I acquired a FTDI USB/Serial cable.



I hate to repeat, but please follow carefully the procedure as described in App. A (and possibly also App. G) of the manual and it shall work: this includes MySamba, an FTDI USB/serial converter, and maybe more you may need.

On my site, it works both with FTDI converter + Gene's flashing cable or Harald's USB board + standard USB cable -- always under Windows 7.

Edited: 3 Sept 2013, 10:59 a.m.


+1. I've been able to make it work under Seven & XP, with MySamba and with Sam-BA 2.10.

And even sometimes on a Mac & on Linux using my own flashing tool but this is less reliable.

Trying many times may sometimes be necessary (i.e. 10 or 20).

Edited: 3 Sept 2013, 1:04 p.m.


I dug up an old enough laptop with a "real" (COM1, on irq4 and port 3F8), and it finally worked. I wonder what the code was trying to do that was failing for the usb cable I had, or the PCI card with the serial ports. I didn't see anything suspicious when strace-ing the process, but if it works, it works!

Thanks to all who responded.

Off to write my own firmware now!


Good news!

I have yet to see a bad cable. It is almost always one of these problems first:

1) Not following the procedure exactly as written. I have fallen into this trap several times myself.
2) OS issue talking to the ports, etc.
3) Computer port hardware issue.
4) Samba software not talking to the proper port, not working at all, etc.
5) Bad calculator.

Only after all those have been completely examined should the cable be considered as at fault. There's just nothing in the cable that can really go bad easily at all.

Glad things worked!


One of mine needed constant pressure on the connector to alllow flashing.


That's why God made rubber bands :)


Glad to see it worked. The problem is that the boot code in the chip cannot assume a crystal being available so it tries to guess the proper oscillator settings iteratively. That's why the host sends several packages of data to synchronize the connection. The whole process is flaky at best.

One common problem with flashing is that the calculator is properly erased but not turned on. There is no visible indication that the chip is powered on. You can just press ON long enough to make sure. Interrupting power will turn it off again.

Possibly Related Threads…
Thread Author Replies Views Last Post
  WP-34s ISP (flashing cable) again ;( Bernhard 16 5,887 11-01-2013, 05:02 PM
Last Post: Bernhard
  Re: [WP34S] Flashing Issues Les Wright 22 6,009 10-30-2013, 02:16 PM
Last Post: Les Wright
  help flashing a hp30b to a wp34s john mantooth 3 1,678 09-25-2013, 08:58 AM
Last Post: Thomas Chrapkiewicz
  Flashing cable for HP 20 / 30B Stefan Koenig 3 1,996 09-19-2013, 05:53 AM
Last Post: Marcus von Cube, Germany
  USB flashing/Li-po boards patryk 6 2,493 09-08-2013, 12:31 PM
Last Post: patryk
  Flashing at HHC2013 Kiyoshi Akima 1 1,150 08-30-2013, 09:12 AM
Last Post: Matt Kernal
  Self-made WP-34s flashing cable? Victor Koechli 6 2,966 08-15-2013, 10:11 AM
Last Post: Les Wright
  wp34s flashing successful at last Glenn Becker 2 1,470 08-04-2013, 04:33 PM
Last Post: Walter B
  trouble flashing wp34s under Linux Glenn Becker 8 2,798 07-23-2013, 02:21 AM
Last Post: Marcus von Cube, Germany
  HELP! WP-34S (Flashing Issue) Barry Mead 2 1,430 07-15-2013, 04:25 AM
Last Post: Marcus von Cube, Germany

Forum Jump: