WP34s Flash Question

I know I'm late to the party but...I am attempting to flash an HP30b to WP34s under Fedora 12. I run MySamba under Wine and the serial port list is empty. My serial port is "ttyS0" (via a "dmesg | grep tty") so I type that in the "connect to" box. After connecting the calculator to the port, and toggling the cable buttons as per the instructions, I press "Send File" but rather than downloading I get an error message from MySamba "Error, could not connect to calculator". Of course I have now erased the calculator and so cannot turn that on (or is it off) in order to repeat the procedure. I also don't know how to correctly specify the serial port or if that is in fact the problem. Any ideas anyone? Thank you.


Maybe >>>this<<< helps.


Edited: 18 June 2012, 9:34 a.m.


No amount of restarting MySamba seems to help. I guess my questions boil down to:

(i) Does MySamba accept text input for the port ID and if so what is the correct format (if not how does one get a populated drop down list)?

(ii) Now that the calculator is erased, and can no longer be (visibly) turned on how does one get it into a state suitable for flashing ?


I also tried Pascal's tool wp34sflashcmd. This returns the error "Cannot open serial port" on two different linux boxes.


Then you probably have a problem with your serial port... The flashing tools can have problems opening the communication with the HP30b/WP34s but as far as I know, that's all.

"Cannot open serial port" means it cannot open the device you gave as an argument. So you have a problem somewhere with your driver, configuration, cable... Or another program has the serial port already opened...


Thanks, Pascal. How does one debug a serial port problem and does the state of the calculator affect the program?


OK, the "Cannot open serial port" was merely a permissions problem. Now wp34sflashcmd crashes with:

./wp34sflashcmd: symbol lookup error: ./wp34sflashcmd: undefined symbol: _ZN13QElapsedTimer5startEv


This is better :-)

It comes probably from your QT version being too old. Can you check it?


I have installed:

qt-1:4.6.3-8.fc12 (i686)

qt3-3.3.8b-28.fc12 (i686)


Hi rgray, I use Mysamba without problems under Linux with Wine, but there are two things I had to do to make it work:

- Create a symlink in Wine's dosdevices folder, which I called com1 and which points to the actual port (in your case I suppose "/dev/ttyS0);

- Give my regular user the permission to use modems (as on my system, that port is seen as a modem).

After that, I can simply run MySamba, type com1 in the port field, and it just works.



You need at least QT 4.7 or 4.8 to run the WP34s Qt programs.


Hi Pascal, I have discovered that I actually have qt-4.6.3-8.fc12.i686 installed (excuse my linux ignorance) but have been unable to find an rpm for 4.7 or 4.8 for fc12. I guess this means I must compile it myself.


Hi Cristian, your information was very helpful and I now can run MySamba (semi) successfully. This of course leads to my next question - since I erased the calculator firmware in my first unsuccessful attempts and hence cannot now (visibly at least) turn the machine on, what sequence of steps do I need to follow to successfully reflash i.e. presumably some series of cable button pressing. MySamba runs but says "unable to connect" (note this is a completely different message from my previous serial port warnings).


If you have added to your user permission to use the serial port (or modems, depending on how your distro handles this - I use Ubuntu and here it's called modems), it should work, as long as the symlink is good.
To flash it, and to be sure it's on, I usually press Reset on the cable and then On on the calculator. But (I might well be wrong) I seem to remember that in the "flash erased" state, you can't turn off the calculator; so if you left it like that for many hours, it's perfectly possible that the batteries have gone flat.
I personally would try Reset+On, then if it doesn't work I'd put fresh batteries and try again, if it still doesn't work there's something to sort out with serial comms - but while experimenting remove the fresh batteries! :)



You can download it here:


Then change the library path. Another solution would be for me to add the dynamic libs to the flash & emulator distribs but this is low priority and I'm afraid it may create other problems.


Hi Pascal, I installed Qt 4.8 via the link you supplied and altered the library path. Now when I run wp342flashcmd I get

"Trying to connect"

and after a brief delay

"Cannot connect to WP34s"

Would this have something to do with the state which the calculator is in? Recall that on my first unsuccessful flash attempt the original firmware was erased and so the display is now blank. I have replaced the batteries as suggested.


Connecting to the WP34s is an act of faith more than anything else :-)

On some platforms, I do it relatively quickly, on others it is a long & painful process...
Sometimes, I have to try reset+on or the whole ERASE+RESET, ERASE+ON, RESET ON many times.

No guarantee here, I'm still trying to find a way to make it more reliable. The problem is not on my side of the program as I reproduce what MySamba and SAM-BA do but somewhere between the driver and the way the WP34s tries to adapt itself to the serial port speed.


Hi Pascal. After many attempts, using every possible combination of cable buttons, I gave up and switched to another machine, different hardware but also running Fedora 12, and it worked first time. I still don't understand what is different but thanks for the help.


I do not understand either.

Possibly Related Threads…
Thread Author Replies Views Last Post
  DIY HP 30b WP 34s serial flash/programming cable Richard Wahl 2 2,525 12-04-2013, 11:14 AM
Last Post: Barry Mead
  PRIME: re-format the flash drive to recover the operating system Harold A Climer 2 1,719 11-06-2013, 12:22 AM
Last Post: Michael de Estrada
  Bad Flash in HP Prime Han 11 3,239 09-27-2013, 12:38 PM
Last Post: Han
  Flash Flood Warning: 9/16/2013 (One Week from HHC13) Eddie W. Shore 8 2,861 09-17-2013, 09:20 PM
Last Post: Craig Ruff
  FLASH? command Andrew Nikitin 1 1,208 06-18-2013, 01:02 AM
Last Post: Walter B
  [EXCLUSIVE FLASH] Infos about new HP Prime ! Mic 16 4,065 04-02-2013, 11:06 AM
Last Post: Frank Boehm (Germany)
  No luck getting flash disk to work in 95lx Harald 7 2,941 03-18-2013, 08:11 AM
Last Post: Harald
  Simple? programming question [WP34S] Shawn Gibson 3 1,447 03-15-2013, 11:56 AM
Last Post: Didier Lachieze
  [wp34s] xtal question jerome ibanes 9 2,911 02-05-2013, 05:35 PM
Last Post: Massimo Gnerucci (Italy)
  [41CL] Repairing an image in Flash Monte Dalrymple 0 890 01-24-2013, 07:01 PM
Last Post: Monte Dalrymple

Forum Jump: