WP34s STATs Prediction Question
#1

I either don't understand how this function works or there is a bug with it...

I enter the following X & y values with Sigma+

Y,X
36,6
25,5
81,9
100,10

With each entry the wp34s shows the number of entries as expected.

I do a STAT BestF then I key h-6(L.R.) and the top area says Power. X register is -6.09818323034e-14 and y register is 2. So far so good.

Now I key in 4 and press f-6 for a predicted y but instead of 16 I get 8.

Edited: 11 June 2011, 9:15 p.m.

#2

Looks like a bug. I know I had this working at one stage :-(
Fix will come.


- Pauli

#3

I believe it is a general fitting error as Exp mode doesn't work either. It seems the linear model is used no matter what.

#4

The parameters were being calculated correctly using the appropriate model but a linear model was used after that. Must have lost the correct code somewhere along the line :-(

Updated version is in subversion now.


- Pauli



Possibly Related Threads...
Thread Author Replies Views Last Post
  Stats functions on the HP34S Nicholas van Stigt 5 299 09-24-2013, 02:45 AM
Last Post: Nick_S
  Simple? programming question [WP34S] Shawn Gibson 3 238 03-15-2013, 11:56 AM
Last Post: Didier Lachieze
  [wp34s] xtal question jerome ibanes 9 417 02-05-2013, 05:35 PM
Last Post: Massimo Gnerucci (Italy)
  [WP34S] WP34S firmware on the AT91SAM7L-STK dev kit? jerome ibanes 1 187 10-04-2012, 04:59 PM
Last Post: Paul Dale
  more question regarding complex operations using complex number on wp34s wildpig 22 701 09-02-2012, 12:54 PM
Last Post: Walter B
  WP34S solver question Reth 22 903 07-13-2012, 06:55 PM
Last Post: Paul Dale
  WP34s Flash Question rgray 18 593 06-19-2012, 03:20 AM
Last Post: Cristian Arezzini
  Another stupid WP34S question Geoff Quickfall 2 169 06-16-2012, 11:21 PM
Last Post: Geoff Quickfall
  WP34S beginner question Geoff Quickfall 8 326 06-08-2012, 09:55 PM
Last Post: geoff quickfall
  [WP34s] Assembler question fhub 6 257 05-14-2012, 03:08 PM
Last Post: Marcus von Cube, Germany

Forum Jump: