HP97 restore project
#1

Hello everybody, this time I'm dealing with an HP97. It is in very good cosmetic condition, but it doesn't work ... I have already taken apart all the main components, which I will restore later (the printer group, the card reader) and I'm concentrating on the two main boards. I have already re-soldered all the points, and the only thing I have on the display is a faint (very faint) zero in different positions whan I press some of the keys like the SST, BST . I have tried with the power supply only, the battery only and the combination of both power sources. Does anybody have a good idea ? Take care,and thanks in advance for your replies, Alberto

#2

Ciao, Alçberto;

I do not have much experience with Topcats, but I have an HP97 and it had a nonworking card reader(/writer). The rest of it works fine, so I never had to deal with its internals. About the card reader, I had to adjust the many contact lids (three, IIRC), and it is not that hard.

Again, be careful when using the charger. The HP97 has a different power circuit when compared to the HP67. In the HP67, the charger has three wires (unregulated Vcc, regulated Vcc and common), but the HP97 uses a two-wire AC adapter. So, it depends on batteries installed to work safely. In the 80's, I once had my first HP82143A (HP41 peripheral printer) damaged just for plugging the AC adapter and turning it ON without batteries. I did not have to wait for a 'twice in a lifetime' to remember it for good!

The behavior you describe actually leads to a bad ACT (main processor), but as you have a good experience with the HP25, go ahead. And keep in mind that the Woodstocks and Topcats share the same ACT processor (except for the HP27, which uses V-MOS technology). In most cases a 'transplantation' is feasible.

Success!

Luiz (Brazil)

#3

Unfortunately not much of a success till now.
Since I have a working HP97, I tried mixing the pieces, and that's how it went.
The keyboard/diplay of the faulty unit is not working, even when installed on the knowing working base.
I have soldered the display flat cable directly to the pcb, but with no improvements at all.
The base unit (of the supposed faulty machine) with the known working display units has some life in it ... the display says 0.00 for a second or two, than shuts off ...
I went for the IC replacement, but to my surprise the IC used on the HP97 (mine is an HP97 post release of the HP 97/S production)do not share the same ACT then Woodstock's one, I'll post the list later today.
It must be said that the faulty unit was in nice cosmetic condition, with no corrosion at all, but both motherboards shows some opaque areas, like some solvent was dropped over ... I have ordered some deoxidation spray and I'll test it.
If anyone has a suggestion, meanwhile my soldering stuff has got broken and I have ordered a new low power one, I'll be happy to read them. Take care Alberto



Possibly Related Threads...
Thread Author Replies Views Last Post
  FRAM71 Project aj04062 1 549 11-25-2013, 01:59 PM
Last Post: Hans Brueggemann
  [HP-PRIME] QPI project CompSystems 0 394 10-09-2013, 02:51 PM
Last Post: CompSystems
  RPN-1200 Project Benoit Maag 0 386 08-25-2013, 01:05 AM
Last Post: Benoit Maag
  Disaster: help for a couple of HP97 needed! Jose Gonzalez Divasson 10 1,298 01-21-2013, 04:45 PM
Last Post: aurelio
  What do you think of this project??? Pierre 1 515 11-21-2012, 06:58 PM
Last Post: Eddie W. Shore
  Archive an HP 50G and Restore on an HP 48GX Rudy P. 5 891 11-16-2012, 09:24 PM
Last Post: Michael Lopez
  TI 2550III project, help me I can help you. watchdoctor 2 566 10-19-2012, 10:13 PM
Last Post: Joerg Woerner
  neat project for the HP48 Han 5 827 09-25-2012, 04:58 PM
Last Post: Han
  What do you think of this project??? Namir 10 1,186 09-16-2012, 03:56 PM
Last Post: Eddie W. Shore
  Charging Current in HP97, 82143A, 82162A Les Wright 5 919 06-17-2012, 02:11 PM
Last Post: Les Wright

Forum Jump: