HP Forums
HP-41 Synth. Progr. Question - Printable Version

+- HP Forums (https://archived.hpcalc.org/museumforum)
+-- Forum: HP Museum Forums (https://archived.hpcalc.org/museumforum/forum-1.html)
+--- Forum: Old HP Forum Archives (https://archived.hpcalc.org/museumforum/forum-2.html)
+--- Thread: HP-41 Synth. Progr. Question (/thread-98787.html)



HP-41 Synth. Progr. Question - Olaf - 08-31-2006

Hi again,

i just asked a question here about the byte grabber... and there is the next problem already.
In the HP-41 Software Library on MoHPC is a program called morse code. In the program are 2 tones used, "TONE 8" and "TONE P".
I didnt manage to get the "TONE P" yet.
According to the byte code table i would take 0x50 which is a P.
So i would key in "STO IND 31" to get the Tone followed by "LN" for the P.
But what i get is a Tone 0.
I read about that the Tone command maybe can not display the characters but the tone (sound) is definitely the wrong one.

So, can anybody give me a hint how to enter those "TONE P" ?

Thanks in advance,

Olaf


Re: HP-41 Synth. Progr. Question - Virgilio Guillen - 09-01-2006

Quote:

So, can anybody give me a hint how to enter those "TONE P" ?

Thanks in advance,

Olaf


Hi,

To create TONE P you can type:

STO IND 31
X=Y?

then apply the byte grabber to the STO instruction.
Note that the status register P 0x78 is different from the letter P 0x50


Re: HP-41 Synth. Progr. Question - Olaf - 09-01-2006

Thanks a lot!!!

That works :-)

I thought the P with the arrow was not the P shown in the Program listing...

Greetings,

Olaf