HP Forums
42S Programing Problem - Printable Version

+- HP Forums (https://archived.hpcalc.org/museumforum)
+-- Forum: HP Museum Forums (https://archived.hpcalc.org/museumforum/forum-1.html)
+--- Forum: Old HP Forum Archives (https://archived.hpcalc.org/museumforum/forum-2.html)
+--- Thread: 42S Programing Problem (/thread-70678.html)



42S Programing Problem - Trent Moseley - 03-19-2005

I somehow screwed-up and got .END. in my program catalog as a program! How do I get rid of it on the program menu?

The program reads thus:

00 (0-Byte Prgm) 01 .END.

tm


Re: 42S Programming Problem - Karl Schneider - 03-19-2005

Mine (S/N 29nnAnnnnn) does that, too. I think that it's the permanent .END. instruction (note: 0-byte program), as the 41's have in program memory. It also serves as an entry placeholder for the next user program.

Entering an external label in the program, then "CLP"'ing the program, does not eliminate the .END. "program".

-- KS


Re: 42S Programing Problem - Raymond Del Tondo - 03-19-2005

That's the permanent .END.

Your calc always maintains this .END.

Maybe the manual could help?

Raymond


Re: 42S Programing Problem - Chad Wagner - 03-20-2005

Trent,
Go to your last program you entered and delete the END from the end.
The permanent END will take it's place and you will no longer have an .END. in your program menu.
Hope that helps.
-Chad


Re: 42S Programing Problem - Trent Moseley - 03-21-2005

Chad,

Your solution worked! Tks.

tm


Re: 42S Programing Problem - Chad Wagner - 03-21-2005

tm,

You're welcome.

Chad


(deleted post) - deleted - 03-21-2005

This Message was deleted. This empty message preserves the threading when a post with followup(s) is deleted.


Re: Worked for me, too. Thanks! [NT] - Chad Wagner - 03-21-2005

Now that I think about it I believe the thanks actually should be pointed at Ted Kerber at D'Zign. I think I saw that in one of his 42s surveying program books something like seventeen years ago.

If you guys ever run across one of Ted's old booklets called "Urban Survey Programs" LET ME KNOW! I want a copy.
It is the only one I do not have and it REALLY bugs me.

Chad