HP Forums
HP75 Memory Exp. Pod - Printable Version

+- HP Forums (https://archived.hpcalc.org/museumforum)
+-- Forum: HP Museum Forums (https://archived.hpcalc.org/museumforum/forum-1.html)
+--- Forum: Old HP Forum Archives (https://archived.hpcalc.org/museumforum/forum-2.html)
+--- Thread: HP75 Memory Exp. Pod (/thread-6550.html)



HP75 Memory Exp. Pod - Mike Davis - 10-28-2000

I have obtained an HP-75 Memory Expansion Pod with a working HP75 but I have no documetation on what the pod offers or how it works.

It has two phone jacks on the back.

Seems to have a modem connection as when it starts up it says "initializing modem" or something like that. Hard to catch that message.

The HP Museum says it is a 7271A but the photo shows more digits (hard to read) so I don't know the real part number.
If it is a memory exp. pod, does it come with extra memory? How much and how does one access it?

The "Mem" function only returns about 22K, when executed.

Anyone know where I can get information on this?

Also, I notice that my 75 has some sort of internal module, in the battery compartment, that says backup. What is that and how is it used?


Re: HP75 Memory Exp. Pod - Jim L - 10-28-2000

There's a manual for this on the HP Museum CDROMs. I just browsed it and it covers a modem, electronic disc, and some additional bar code software. I might be able to answer a specific question but it's a 123 page manual so it's hard to summarize in a post.




Re: HP75 Memory Exp. Pod - Mike Davis - 10-28-2000

I'd be interested in commands to access or test the Modem, Electronic Disc (is this in all pods?) or see if it's even there.

Anything like that? Some basics to exercize and see if this works?

Thanks


Re: HP75 Memory Exp. Pod - Jim L - 10-28-2000

To initialize the modem

MODEM OFF

MODEM ON

then wait about 5 seconds and

PRINT MODIN$

to display the result. If it's blank, wait a while longer and print again.

To initialize the electronic disc execute

INITIALIZE ":XMEM"


Re: So far so good - Mike Davis - 10-29-2000

Modem On (seems to take)
Print modin$ (returns OK; seems to work)

Modem Off (seems to take)
Print modin$ (returns Error Modem Off; seems right)

Tried
modout "test" (guessed at this; seem to take)

Initialize "XMEM" (seemed to work)
Tried
XMEM (returned 65xxx; seems like it has 64K)

Guess I'll have to try and find a manual for this expansion pod. Probably a million other commands.

Thanks,