HP Forums
HPIL PC board: works but test keeps failing - Printable Version

+- HP Forums (https://archived.hpcalc.org/museumforum)
+-- Forum: HP Museum Forums (https://archived.hpcalc.org/museumforum/forum-1.html)
+--- Forum: Old HP Forum Archives (https://archived.hpcalc.org/museumforum/forum-2.html)
+--- Thread: HPIL PC board: works but test keeps failing (/thread-49762.html)



HPIL PC board: works but test keeps failing - Giuseppe Marullo - 01-06-2004

Hi all,
following the advice that the bus could be too fast, I got a 486DX33? and installed the whole stuff, and used a copy of TRANS41.
It worked, at least I understand so. I was able to dump whatever I wrote, programs back and forth, etc.

Just to be sure, I tried the test that should be part of the software that came with the board.
It failed, HPIL link is broken.
So now, I suspect that TRANS41 could work on the faster pc, but also other stuff could work.

I am waiting the enanched EMU41 program to test it on both machines.

Which is the fastest machine on which you were able to run the HP82973 board?

TIA,

Giuseppe Marullo


Re: HPIL PC board: works but test keeps failing - Christoph Klug - 01-07-2004

Dear Guiseppe,

you are right, original HP software and LINK PLUS have speed limits, and only run correctly with old low speed PC hardware. This limites depends on software - not on hardware.

TRANS41 and EMU41 do not include speed problems - I use them with a 800MHZ PC and with a 1GHz PC without any limitation.

For modern operating systems like WIN2000/XP/NT you have to install the additionally software tool for address routing...

Best regards from Germany - Christoph Klug


Re: HPIL PC board: works but test keeps failing - Giuseppe Marullo - 01-07-2004

Christoph,
thank you for your answer. Since I plan to use mainly EMU41 (and maybe TRANS41), I will surely try to make it run on the PII. I simply don't know what could be useful to me, EMU41 seems the killier app here.

BTW, what do you mean with "software tool for address routing..." ? Are your referring to something able to make direct I/O access under w2k/XP, like inpout32, userport etc?
TIA,

Giuseppe Marullo


Re: HPIL PC board: works but test keeps failing - Christoph Klug - 01-08-2004

Dear Guiseppe,

yes - for I/O access i take the userport software tool....

Regards from Germany - Christoph Klug


Re: HPIL PC board: works but test keeps failing - Giuseppe Marullo - 01-08-2004

This sounds cool, so you could perform hpil within w2k and XP.
For example, I could write a HPIL sniffer using Delphi.

Any snipplet of cod you could share? :)