HP Forums
HP-IL problem - Printable Version

+- HP Forums (https://archived.hpcalc.org/museumforum)
+-- Forum: HP Museum Forums (https://archived.hpcalc.org/museumforum/forum-1.html)
+--- Forum: Old HP Forum Archives (https://archived.hpcalc.org/museumforum/forum-2.html)
+--- Thread: HP-IL problem (/thread-36519.html)



HP-IL problem - David Ramsey - 06-18-2003

Although it worked as recently as last weekend, I can no longer get my 82161A cassette drive to talk to a 41. When I try to issue a "DIR" command on the 41, the message TRANSMIT ERR appears. The same thing happens when I plug the HP-IL module into another 41.

I don't have another HP-IL peripheral, but I can plug the drive into my HP-71B...except I have no documentation on issuing HP-IL commands from this machine. DIR certainly doesn't work!

Suggestions, anyone?


Re: HP-IL problem - Massimo Gnerucci (Italy) - 06-18-2003

Is the switch on the lower side of the 41 module in the correct position?
Just a guess...

Massimo


Re: HP-IL problem - Christoph Klug - 06-18-2003

The switch is only for enabel/disabel the internal printer feature of the IL-Module.

Remove the IL-Cass-Drive from the loop and close the loop. Now execute DIR . If you get the message NO DRIVE your IL-Module works nice - if you get the massage TRANSMIT ERR the bug is limited to the IL-Module (not to the IL-Cass-Drive, I hope so).

Best wishes from Germany - Christoph Klug


Re: HP-IL problem - Johnny Billquist - 06-18-2003

When I get that error, I normally have low power in the casette drive. My battery is getting bad and I should replace it.
You might have the same problem. Is the low bat indicator lit on the drive?
I have written a little program to test the memory in the drive as well, which might be useful. It requires that you have the Extended I/O module though.
I can post that program if required. I wrote it when I had a problem previously with my drive, which turned out to be a broken memory IC in the drive.


Re: HP-IL problem - David Ramsey - 06-18-2003

Damn. Plugging the ends of the HP-IL cables coming out of the module together and executing DIR still gives TRANSMIT ERR.

If I try any HP-IL commands with the tape drive connected and turned off, there's a pause before TRANSMIT ERR appears.

And making sure a new, freshly charged battery is in the tape drive (which was also plugged into AC) didn't help.

Anyone have an HP-IL module they want to sell?


Re: HP-IL problem - Vieira, Luiz C. (Brazil) - 06-18-2003

Hi, David;

TRANSMIT ERR message will also appear if the loop is opened. If you have this message when you close the loop by plugging both ends together, chances are you have a "broken cable". If this is my unit, I'd open it and check if all four wires are integral and conducting alright. You can also slightly move and gently twist the cables close to their ends and repeat the DIR command (assign it to a key to easen the job). Maybe you get NO DRIVE message.

This also means you'll have to find where the cable is broken and repair it (or cut part of it off). In any circumstances, this means an easy repair with some time to be spent...

Success. And let us know what you want or will do.

Luiz C. Vieira - Brazil


Re: HP-IL problem - David Ramsey - 06-18-2003

I thought about that (simple broken conductor).

I can fix things like that-- I've replaced bad LED modules in classic HP calcs, so I should be able to do this.

How does the module open? Is it snap-apart?


Re: HP-IL problem - Ellis Easley - 06-18-2003

If you do find that one of the wires is open, look for a multimeter with a capacitance range. I used one the other day on the cord for a Classic battery charger. As it turned out, the break was at the plug end, but the total capacitance between adjacent wires in the 8 foot cord was about 200 pf, easily measured on the meter's 2000 pf range. If the break had been someplace other than at the end, I could have measured the capacitance from both ends and used the ratio of the measurements to narrow down the location. (In fact, I measured 200 pf from one end and 4pf from the other.)


Re: HP-IL problem - David Ramsey - 06-18-2003

[quote]
If you do find that one of the wires is open, look for a multimeter with a capacitance range. I used one the other day on the cord for a Classic battery charger. As it turned out, the break was at the plug end, but the total capacitance between adjacent wires in the 8 foot cord was about 200 pf, easily measured on the meter's 2000 pf range. If the break had been someplace other than at the end, I could have measured the capacitance from both ends and used the ratio of the measurements to narrow down the location. (In fact, I measured 200 pf from one end and 4pf from the other.)
[\quote]

This goes beyond my simple understanding of basic electronic theory. But I'll make a note of it.


Re: HP-IL problem - Ellis Easley - 06-18-2003

Maybe I should say more properly, the ratio of the capacitance measured at one end to the sum of the capacitances measured at each end. The capacitance should be proportional to the length of the continuous pair of wires. For example, if you measured the same capacitance from both ends (and you knew that there was a break in one of the wires) then the break would be near the middle of the length. If you measured three times as much capacitance from one end as from the other, the break would be about a quarter of the way from the end with the smaller capacitance measurement.


Re: HP-IL problem - Vassilis Prevelakis - 06-18-2003

David Ramsey wrote:
> How does the module open? Is it snap-apart?

Before taking the hp-il module apart, maybe you should
check whether the break is in the plugs on the far end of the cable (the ones that plug into the tape drive). These
take a lot of beating as you plug and unplug them.

One easy way of checking connectivity is to stick a
pin into one of the conductors in the cable and check connectivity between the pin and the corresponding pin on the plug. Check all four wires and if they work, then the
problem is most likely on the connection of the cables with the HP-IL module.

**vp


Re: HP-IL problem - David Ramsey - 06-18-2003

Luiz,

So...how do you open the HP-IL module? Snap together? Fasteners under the label?

-- David


An image of an HPIL opened - Vieira, Luiz C. (Brazil) - 06-19-2003

Hello, David;

I opened some HP41 ROM and memory modules to try to repair them. In two cases I was successful after re-soldering a couple of terminals. Unfortunately I found at least three ROM modules that did not respond to calculator's commands, and they seemed to be perfectly fine inside.

The best procedure is testing the cables and checking if there's a chance not to open it. Avoid opening the HPIL module.

Look at the picture below. It's an opened HPIL. The original image is from the HP Journal, January 1983, p. 11. Im calling attention to two very sensitive components:

(1) - Hybrid pulse transformer
(2) - HPIL custom chip (for the HP41)

As you can see, both halves are "welded" (ultrasound) together by teir borders. The best way to separate the case is to use a tool that allows you to gently "break" it exactly in the "jointing" surface. This is a time consumming task and there are some actual cases that are easier to open than others (it seems that some modules are better "welded" than others, what is a great disadvantage when opening). I remember seeing some pictures (private page) of one contributor opening a memory module, and he used a small knife. I think you'll have a better idea and you'll probably find your own way to open it; consider doing this only if needed. I did not need to open an HPIL so far, but I'll not hexitate if I need to.

If it does not give you a good idea, let me know. I have a memory module for the HP41 that was opened once. If needed, I'll open it and scan some images showing the process.

PLEASE, READ

Keep in mind that your module may be dammaged or have a broken case if you force it too much or if you use a tool that's sharp enough to destroy the internal components. Please, go slow and take necessary precautions to avoid it.

Success.

Luiz C. Vieira - Brazil


Edited: 19 June 2003, 1:22 a.m.


Re: HP-IL problem - Vassilis Prevelakis - 06-19-2003

David Ramsey wrote:
> So...how do you open the HP-IL module? Snap together? Fasteners under the label?

No, the two halves are glued together like ordinary memory modules. Have a look at the following article which explains how to take apart memory modules and follow a similar procedure.

http://www.hpmuseum.org/cgi-sys/cgiwrap/hpmuseum/articles.cgi?read=329

**vp