HP Forums
HP67 display - Printable Version

+- HP Forums (https://archived.hpcalc.org/museumforum)
+-- Forum: HP Museum Forums (https://archived.hpcalc.org/museumforum/forum-1.html)
+--- Forum: Old HP Forum Archives (https://archived.hpcalc.org/museumforum/forum-2.html)
+--- Thread: HP67 display (/thread-29035.html)



HP67 display - Richard Parfitt - 03-05-2003

I have a HP67 which I am sure is working OK! because it runs the diagnostic properly and accepts input and does simple arithmetic. The big problem is the display or lack of it!!.
I only get the middle segment correctly lit all the others are dull but with a magnifying glass I can tell that they are illuminated, but not bright enough.
Everthing is clean inside, and batteries are good (taken from a HP35/HP45 series).
I am suspecting it's the driver chips maybe just below the row of the LED displays, now one of these is a HP product and the other is an RCA chip. Does anybody out there know what my problem might be or how I can fix it, doing small delicate soldering jobs is OK! so if I can replace a chip that is no problem. Can I use the HP chip say from a HP25, HP29?? as according to the HP museum pages the technology in these series of machines is similar and the numbers on the HP chips are the same, (certainly the first number anyway). Thanks in advance for any help, Regards Richard.


Re: HP67 display - David Smith - 03-05-2003

The HP67 has weird drive circuitry. The middle segment is driven independently of the others... it has to do with handling of the minus sign.

The RCA chip is a transistor array used to drive the segments. It is available off the shelf... I think it may ba a CA3082 or CA3080, but can't remember for sure. NTE also has it in their replacement parts line. It could very well be the cause of your problem.

The HP chip is a custom shift register used to scan the digits. It would need to be salvaged from another machine. If the part number matches, it is the same chip. There is also a two transistor current sink on the CPU card used in the display drive system.

Finally the "ROM0" chip on the CPU card also contains the segment drive logic. It is located on the left side of the CPU card (I don't remember the part number) This chip is powered through a low valued resistor (like 47 ohms or so). This resistor sets the drive level of the display segments (except the center segments). Your problem could also be with this chip or resistor... it is unique to the HP67.


Re: HP67 display - Richard Parfitt - 03-07-2003

Thanks for the info, I will pursue all channels and post a solution when I find one.