HP Forums
[HP Prime] Using n-root symbol and exponent problem - Printable Version

+- HP Forums (https://archived.hpcalc.org/museumforum)
+-- Forum: HP Museum Forums (https://archived.hpcalc.org/museumforum/forum-1.html)
+--- Forum: Old HP Forum Archives (https://archived.hpcalc.org/museumforum/forum-2.html)
+--- Thread: [HP Prime] Using n-root symbol and exponent problem (/thread-255313.html)



[HP Prime] Using n-root symbol and exponent problem - uklo - 11-09-2013

Why is this happening?

It is not the same? :(




Re: [HP Prime] Using n-root symbol and exponent problem - Les Koller - 11-09-2013

Hmmm, that is strange. Hope someone figures it out. HP 50G gives same answer either way (the answer you have second).


Re: [HP Prime] Using n-root symbol and exponent problem - Richard Berler - 11-09-2013

Odd...I got the same result (top screen) on both Home and CAS regardless of maximum or none for auto simplification. The 2 results are correct...how does one get the simplified result for the 1st case?


Re: [HP Prime] Using n-root symbol and exponent problem - uklo - 11-09-2013

I'm not sure if both answers are correct. I did it using 2 other CAS: wolfram alpha and Pocket CAS (for iOS) and i got the second result on both. I plot them and the result is a hyperbola, but the first result is only the positive side of that hyperbola... that's weird, obviously the second result is the correct one.

I hope this get fixed soon *O*


Re: [HP Prime] Using n-root symbol and exponent problem - Terje Vallestad - 11-10-2013

Quite interesting, but if you use the Sto command and store both expressions into F1 and F2 for plotting, both show the second answer 2/(6x-3). So presumably only the second answer is correct?


Re: [HP Prime] Using n-root symbol and exponent problem - Richard Berler - 11-10-2013

I was thinking that (x^(-a))*x^(+a)=x^0=1 which would produce the numerator of 2 in the example.


Re: [HP Prime] Using n-root symbol and exponent problem - Terje Vallestad - 11-10-2013

Yes I believe (know) you are correct. I was more thinking of the anomaly that when the two expressions (that showed such different expressed results on the CAS screen) were stored into variables they both showed the latter more simplified result.


Re: [HP Prime] Using n-root symbol and exponent problem - Alberto Candel - 11-11-2013

I believe that for the HP Prime the nth root symbol (n odd) of a real number x and the power x^(1/n) are different things. The power x^(1/n) is computed as exp((1/n) LN(x)). If x is negative, then the HP Prime computes LN(x) as the complex number LN(|x|)+ i*pi (principal determination of the logarithm). For the nth root symbol of x, the HP Prime returns x^(1/n) if x is positive and -|x|^(1/n) is x is negative. So the results differ by the multiplicative constant exp(i*pi/n). This should not be a difference for the computation shown because taking LN makes the difference into an additive constant which then should disappear when taking the derivative. I suspect that the HP prime uses different algorithms to simplify each expression.

By the way, the HP50g interprets the nth root of x and the power x^(1/n) the same way, as exp((1/n) LN(x)) with LN(x)=LN(|x|)+i*pi if x is negative.