HP Forums
Digging for bugs - Printable Version

+- HP Forums (https://archived.hpcalc.org/museumforum)
+-- Forum: HP Museum Forums (https://archived.hpcalc.org/museumforum/forum-1.html)
+--- Forum: Old HP Forum Archives (https://archived.hpcalc.org/museumforum/forum-2.html)
+--- Thread: Digging for bugs (/thread-255041.html)

Digging for bugs - Stefan Dröge (Germany) - 11-06-2013

I tried to cause some strange behaviour and were successful:

When I am on a input line and then press the keys "x^y", "sin", "cos", "tan" one after another, chinese symbols appear on the input line.

There are several combination which lead to similar errors. One more example is "x^2", "+/-", "( )", "," "( )", "+/-" "x^2".

A similar phenomenon is when you type "x^2", "+/-", "( )", "," only two more key presses seem to be accepted and are shown on the input line.

The symbols are not always the same (i.e. they are different depending on whether I am in the CAS or the numeric environment).

The simulator does not show this behaviour.

- Stefan

Re: Digging for bugs - Terje Vallestad - 11-06-2013

What settings have you got? I tried to input the sequences as you described in both textbook and algebraic and in Home N CAS and could not reproduce any Chinese symbols?

Cheers Terje

Re: Digging for bugs - Stefan Dröge (Germany) - 11-13-2013

Sorry for the late response. After resetting the device I could not reproduce the behavior either. However I am pretty sure that I have not changed the default settings before I saw the error. The only thing I remember is that I had activated the exam mode before I saw the bug (but I encountered the bug while I was NOT in exam mode). And I also remember copying large amounts of text.

Too bad that I could not find a way to reproduce the error :-(