HP Forums
trouble flashing wp34s under Linux - Printable Version

+- HP Forums (https://archived.hpcalc.org/museumforum)
+-- Forum: HP Museum Forums (https://archived.hpcalc.org/museumforum/forum-1.html)
+--- Forum: Old HP Forum Archives (https://archived.hpcalc.org/museumforum/forum-2.html)
+--- Thread: trouble flashing wp34s under Linux (/thread-246692.html)

trouble flashing wp34s under Linux - Glenn Becker - 07-18-2013

Hi --

After a long wait, I tried tonight to flash my wp34s (HP30b type) with the release from 3-7-2013.

So far I have had no luck getting past "Cannot connect to WP34s". I'm using a laptop running Slackware Linux 14.0 with a docking bay (w/serial port on it) connected via a USB port. I'm assuming (maybe a bad thing) that the serial port I'm trying to connect through is /dev/ttyUSB0.

I first run setserial and get the following:

# setserial -G /dev/ttyUSB0
# /dev/ttyUSB0 uart 16654 port 0x0000 irq 0 baud_base 460800 spd_normal

... which, I guess, looks okay to me. Then I run

./wp34sflashcmd ../wp34s/real/calc_xtal_full.bin /dev/ttyUSB0

and get the "Cannot connect" message.

After searching the message board I did find a recommendation that I press RESET and then ON before flashing, so I tried this. Curiously, I do not get the expected click when I poke a paper clip into the 'RESET' hole, so I don't know whether the reset is somehow fouled up, or what. I've removed the three screws from the back of the unit to see if I could pry it off and scope out what might be wrong with the reset button, but so far I've had no luck getting the thing to come apart.

So currently I have a dead HP30B/wp34s. If anyone can suggest a reasonable next step, I'd be happy to try it. I could perhaps try connecting under a different flavor of Linux.


Re: trouble flashing wp34s under Linux - Barry Mead - 07-18-2013

I noticed the same trouble. I can talk (send registers & progs) to/from the calculator with the QT simulator in linux by setting the Edit, Preferences, Serial Port to "/dev/ttyUSB0", but the linux flashing program does not work for me either. (I was using Debian
Wheezy linux).

If you can find a windows machine and download the MySamba.zip file
from http://sourceforge.net/projects/wp34s/files/FlashTool/
You will be fine.

Look in the Device Manager under USB devices to find out which
com port is a USB serial port.

Select the desired file and the appropriate serial port in the MySamba program. Press the reset on the back and the ON button on the front if your calculator is in the "Apparently Dead" state, then click on the "Send File" button in the MySamba program.

Edited: 18 July 2013, 10:03 p.m.

Re: trouble flashing wp34s under Linux - Barry Mead - 07-18-2013

Also if you want to open the calculator there are TWO MORE screws
under the outer edge of the bottom rubber foot. Just fold back the very tip of the rubber foot to expose the screw on each end of the foot. This probably isn't necessary, I don't notice any click when
I press the reset button either. I think your calculator is just fine, all you need to do is use the windows flashing program to get it working again!

Edited: 18 July 2013, 10:04 p.m.

Re: trouble flashing wp34s under Linux - pascal_meheut - 07-19-2013

Communication is at 9600 bauds when flashing is at 115200 bauds. And the HP30b does not have a precise enough clock so it is "around" this speed.

This make flashing success very dependent on the chipset & the driver. I had success and failures on Linux and OSX without ever finding a way to make the process more reliable.

I second the previous answer: you should try with a Windows machine and maybe give MySamba a try even if the QtFlash & FlashCmd program implement the exact same algorithm as they are based on MySamba sources.

Re: trouble flashing wp34s under Linux - Glenn Becker - 07-19-2013

I might be able to borrow a Windows laptop from work. I'll ask today.

Thanks for the replies! :^)

Re: trouble flashing wp34s under Linux - Barry Mead - 07-21-2013


Were you able to borrow the windows machine and try the flashing
operation with MySamba? According to what I read in the manual
only two of the older HP-20b calculators were ever damaged to
such an extent where they couldn't be flashed.

So far, they have never had an HP-30b calculator that couldn't be
restored by proper flashing.

Re: trouble flashing wp34s under Linux - Glenn Becker - 07-22-2013

Hi Barry --

No -- they did not have a machine with a serial port here at work.

I actually placed a 'services wanted' ad in the Classifieds here to see whether anyone would be kind enough to do this for me if I paid some $ + return shipping costs. No takers as yet.

At worst I could get myself a cheap used ThinkPad or something, but I'd rather not spend the dough.


Re: trouble flashing wp34s under Linux - Barry Mead - 07-22-2013

It is getting really hard to find serial ports these days. That is why I bought the tiny micro usb converter board and installed it into
my calculator. That way All I need is a standard USB to micro USB cable to flash or talk to the calculator. It isn't an easy install
unless you have all of the right equipment. I happen to have a sterographic surface mount microscope and soldering equipment sized for tiny surface mount parts, so I was able to handle it. For the casual tinkerer it might be a bit too much. Certainly you wouldn't want to tackle it if all you have is a "Weller Soldering Gun" :-)

If you feel up to it you can order the micro USB board from Harald Pott by sending 14.50 Euros through paypal to his email address: h.pott@gmx.net. Harald lives in Germany, so it takes about a week
for the package to arrive to the U.S. If you also need the 32.768Khz crystal and two 18 pf caps to add the real time clock
feature to your calculator, then the total is 14.75 Euros instead.
The crystal is required if you want to flash the calc_xtal.bin (calc_xtal_full.bin) or calc_ir.bin (calc_ir_full.bin), but not required if you use the basic calc.bin (calc_full.bin).

I really like my new micro USB interface right on the calculator.

Edited: 22 July 2013, 6:14 p.m.

Re: trouble flashing wp34s under Linux - Marcus von Cube, Germany - 07-23-2013

Glenn, get yourself a USB-Serial converter with an FTDI chip! They tend to work best for flashing. Thats what I'm using all the time. My setup is an iMac with Parallels Desktop running Windows XP. Parallels routes the USB dongle directly to the virtual machine. It just works.