HP Forums
go41cx emulator questions - Printable Version

+- HP Forums (https://archived.hpcalc.org/museumforum)
+-- Forum: HP Museum Forums (https://archived.hpcalc.org/museumforum/forum-1.html)
+--- Forum: Old HP Forum Archives (https://archived.hpcalc.org/museumforum/forum-2.html)
+--- Thread: go41cx emulator questions (/thread-236125.html)

go41cx emulator questions - Brian Walsh - 12-16-2012

go41cx is a low cost full-featured 41CX emulator for Android. I have used it on my HTC Thunderbolt and am now really happy with it on the Samsung Galaxy Note 2 with its big 5.5" screen which makes it just about life size (and soooo fast at max. speed). It really is a joy to use on a pocketable smart phone with such a nice big display.

But now that I've been using it more and discovering many of its features and trying to use them, I'm not getting anywhere trying to "plug in" the Hepax. Before you tell me to RTFM, I've tried to do that. If I'm a little rusty I hope you'll forgive that and try to help.

I wrote to Olivier DeSmet (author of go41cx) and to Eric Smith:

The CCD Module seems to load and work fine. I haven't tried any other modules.

On my Samsung Galaxy Note 2 the internal storage is at
I created the directory /storage/sdcard0/go41cx
with /modules under it.

I wasn't sure whether I needed to download HEPAX.MOD but I did anyway and tried storing it in the /modules directory.
In go41cx and pressing the center of the display to 'plug in' the Hepax, it always tells me 'Please turn off calculator'. I go back to the emulator main screen and press and hold down the ON button to turn off the 41, then press and hold down the ON again so the display comes on, but the module never loads.

What am I doing wrong?

Re: go41cx emulator questions - Brian Walsh - 12-16-2012

Olivier kindly replied to a private email, which clarified things a bit. However, I am still confused.

I turned the calculator OFF, then went to the config screen and pressed the Hepax button at the top.
It prompts me to add at least one Hepax RAM module in port 1.
I press port 1 (1: Empty) but all it shows is

Choose module to plug


Where is Hepax RAM?

Edited: 16 Dec 2012, 11:28 a.m.

Re: go41cx emulator questions - Guenter Schink - 12-16-2012

Hi Brian,


Where is Hepax RAM?

It's just at your fingertip :-)

With the calc switched off, go to the screen where you configure the modules. At the bottom you have a button "Hepax". Activate this button, the writing becomes green. Now with the Android Menu key select "new" et voilá, you can create your Hepax Ram, as many as you'd like to. Normal procedure for plugging a module applies afterwards.

Now you can activate the HEPAX module.

HTH, Günter

Re: go41cx emulator questions - Brian Walsh - 12-16-2012

Thank you so much! It worked! :-)