HP Forums
Problem building calc.bin? - Printable Version

+- HP Forums (https://archived.hpcalc.org/museumforum)
+-- Forum: HP Museum Forums (https://archived.hpcalc.org/museumforum/forum-1.html)
+--- Forum: Old HP Forum Archives (https://archived.hpcalc.org/museumforum/forum-2.html)
+--- Thread: Problem building calc.bin? (/thread-215962.html)

Problem building calc.bin? - Ed Wright - 03-29-2012

I can flash my WP34s with calc.bin downloaded from sourceforge reliably, but I cannot flash an image if I build it myself. I run flash.cmd and the log file indicates the build was successful. The error I get from the flash programmer is "no answer to packet xx." That's not an exact quote; I'm not at the right computer now, but it's pretty close. xx is not always the same number. Has anyone seen this or know what I have wrong?

Re: Problem building calc.bin? - Marcus von Cube, Germany - 03-29-2012

Check the size of the file! I assume that your compiler does not produce the same output as mine. The file size must not exceed 128 KB. Has the post processing step been successfully executed? It takes the file calc.tmp, strips off a part that contains the original 4 byte jump addresses in the command tables and replaces the dummy entries by 2 byte equivalents of the original addresses. The resulting file should then be shorter then 128 KB. Without this step the binary will not work.

Re: Problem building calc.bin? - Ed Wright - 03-29-2012


Thanks for the quick reply. Yes, the file is less than 128k. It appears the post processing completed. Below is a cut & paste of the end of the flash-build.log, in case it provides a clue.

I am using an older XP machine with a native serial port, no USB-to-serial adapter.

Revision number(s): 2713M
Revision number will be 2714
arm-none-eabi-gcc -mthumb -mcpu=arm7tdmi -Os -fira-region=one -Wall -Werror -g -fno-common -fno-exceptions -DREALBUILD -Dat91sam7l128 -Iatmel -DXTAL -DNO_BACKUP_INIT -DNO_RAM_COPY -IdecNumber -o realbuild/calc_xtal -nostartfiles -T wp34s.lds -Wl,--gc-sections,-Map=realbuild/mapfile_xtal.txt \
atmel/board_cstartup.S asone.c -nostdlib -lgcc -Lwindows32_realbuild/obj -lconsts -fwhole-program -ldecNum34s -save-temps
arm-none-eabi-nm -n realbuild/calc_xtal >realbuild/symbols_xtal.txt
arm-none-eabi-nm -S realbuild/calc_xtal >>realbuild/symbols_xtal.txt
arm-none-eabi-objcopy -O binary --gap-fill 0xff realbuild/calc_xtal realbuild/calc_xtal.tmp
windows32_realbuild/post_process.exe realbuild/calc_xtal.tmp realbuild/calc_xtal.bin
Post-processing address tables
Monadic commands: 139
Dyadic commands: 42
Triadic commands: 10
Niladic commands: 194
Argument commands: 138
Multi word commands: 11
.fixed 0x00100000 0x1da48
.revision 0x0011da48 0xb8
0x0011db00 UserFlash = .
0x00001d00 UserFlashSize = (. - UserFlash)
.backupflash 0x0011f800 0x800
.cmdtab 0x000f0000 0x1d8c
.bss 0x00200000 0x188
.slcdcmem 0x00200188 0x30
.volatileram 0x002001b8 0x1d0
.persistentram 0x00300000 0x800

Re: Problem building calc.bin? - pascal_meheut - 03-29-2012

Which "flash programmer" do you use? There are 3 of them.

Re: Problem building calc.bin? - Marcus von Cube, Germany - 03-29-2012

Ed, the log looks perfect.

Re: Problem building calc.bin? - Ed Wright - 03-29-2012

Not MySamba or Samba, but the one from the flash directory on sourceforge. It only fails using my builds and never using builds I download.

Re: Problem building calc.bin? - pascal_meheut - 03-30-2012

If its name is WP34sFlash, it is the new one and still in beta.

You should try with MySamba. If you still have the problem, then it comes from your build. If not, from WP34sFlash and then, I would very much like to get one of you calc.bin file to try to reproduce it.

Edited: 30 Mar 2012, 12:10 a.m.

Re: Problem building calc.bin? - Ed Wright - 03-30-2012

Yes, I was using WP34sFlash. I will try MySamba and let you know the resuly, although it may be a couple days before I get back to that XP machine with native serial port. If MySamba works, I will get a copy of my build to you.


Re: Problem building calc.bin? - Ed Wright - 04-03-2012

I tried flashing my calc.bin file using MySamba and it works. Unfortunately, I made another change at the same time so I don't know which change made the difference. I also added the crystal mod. The next time I flash, I will go back to WP34sFlash and see if that works now. The only issue I see now is that when I flash with my version of calc_xtal_full.bin, I don't seem to have the "full" capability. The file size seems correct - very close to the release version of calc_xtal_full.bin. Crystal functionality seems to work, I can run the stopwatch, etc.

Re: Problem building calc.bin? - Marcus von Cube, Germany - 04-03-2012

Ed, send me the contents of your realbuild directory and I can check it out.