HP Forums
Strange HP41CX Problem - HELP! - Printable Version

+- HP Forums (https://archived.hpcalc.org/museumforum)
+-- Forum: HP Museum Forums (https://archived.hpcalc.org/museumforum/forum-1.html)
+--- Forum: Old HP Forum Archives (https://archived.hpcalc.org/museumforum/forum-2.html)
+--- Thread: Strange HP41CX Problem - HELP! (/thread-205194.html)



Strange HP41CX Problem - HELP! - Fouad M. Kaadou - 11-19-2011

Hello Hp museum,

I have recently opened up my Hp41cx to repair what I suspected was a broken screw posts problem but it was only broken posts on the back side of the calculator and by placing them correctly it is now firmly held together.

Now the real problem: After I reassembled the Hp41cx I was plugging in some modules and noticed that if I plugged any modules or card reader or printer or anything into the right ports (ports 2 and 4) the calculator will go crazy and not respond to anything unless I unplug the modules on the right side. The calculator works great if the right ports are empty. The left ports function properly.

Any Ideas? HELP!

Thanks in advance,

Fouad


Re: Strange HP41CX Problem - HELP! - Randy - 11-19-2011

Disassemble and check for foreign matter under/on the i/o port block connector.


Re: Strange HP41CX Problem - HELP! - Fouad M. Kaadou - 11-20-2011

Thanks Randy. I found the problem, but I also have another problem:

I have a card reader that works on my other HP41C but when connected to the HP41CX the calculator would not even recognize that it is plugged in when I run CAT 2. although the port used by the card reader works properly with other modules.

Any thoughts?

-Fouad