HP Forums
Unable to clear HP-41cv MEMORY LOST error - Printable Version

+- HP Forums (https://archived.hpcalc.org/museumforum)
+-- Forum: HP Museum Forums (https://archived.hpcalc.org/museumforum/forum-1.html)
+--- Forum: Old HP Forum Archives (https://archived.hpcalc.org/museumforum/forum-2.html)
+--- Thread: Unable to clear HP-41cv MEMORY LOST error (/thread-19051.html)

Unable to clear HP-41cv MEMORY LOST error - Todd Koumrian - 06-18-2002

Can't seem to clear the MEMORY LOST message despite doing what the manual says....

I just bought an HP-41cv, since I liked it many years ago. There were batteries installed, but incorrectly, and some were starting to leak just a bit. No damage, no acid on the terminals or springs.

However, when I put new batteries the display immediately shows MEMORY LOST without even pressing ON. Further, I cannot clear the error no matter what. I've tried pressing CLX and ON while inserting the batteries, but no luck. Occasionally when I put the batteries in, the display is very faded, but immediately becomes crisp MEMORY LOST when I press a key (keypad is working then??).

Can anyone advise? I have only a couple days to determine if it'll work or I should return it for a refund.


Re: Unable to clear HP-41cv MEMORY LOST error - Ellis Easley - 06-18-2002

Search the Forum (don't forget the archives!) for Memory Lost and other 41C hangups, there are a lot of threads on the general subject. Solutions include various keyboard resets and completely discharging the internal storage capacitor (the one that allows you to change batteries without losing memory). My experience is very limited but I recently got a 41CX with quite dead batteries that wouldn't do or say anything with fresh batteries. After reading about discharging the capacitor, I used an ammeter to short the two outermost battery terminals (so I could see if any discharging was taking place). I had measured about a volt there with a high impedance voltmeter. With the ammeter I measured a current in the .1 to 1 milliamp range that dropped very slowly for a few minutes then stopped dropping at about 20 to 100 microamps (I forget exactly). Then after about 10 or 15 minutes, the current started dropping again and in a few minutes it was too low to measure, so I stopped. (I was hoping to avoid having to open the case and short out the capacitor directly, as there are some (or a) diode(s) between the battery terminals and the capacitor - some people report leaving the battery terminals shorted for ages before the calculator will respond.) In any case, I was lucky and after what I have described, the calculator started up correctly and continues to work fine. I know yours is stuck saying "MEMORY LOST" but it could still be because some illogical information is in the RAM - partially good information that is corrupted from an extemely low (but non-zero) supply voltage.

Good luck!

It's unlike most problems I've read about - Todd Koumrian - 06-18-2002

With mine, it says MEMORY LOST the moment the batteries hit the terminals. Mostly I've read about resetting the calculator when it refuses to turn on. With mine, I've lost control immediately.

I've tried leaving the batteries out for a long period of time. I will try shorting the terminals next. Just doing it for a minute didn't change anything.

Does anyone know if this indicates a memory defect? I have to decide in the next couple of days whether this calc is going to work before my return window disappears.

Re: Unable to clear HP-41cv MEMORY LOST error - David Smith - 06-18-2002

HP41 manuals actually say to put the batteries in backwards for a while to hasten the discharge. There is a protection diode that keeps the full reverse voltage out of the machine, and the 0.7 volt reverse drop will not hurt anything. I have HP41 machines (especially CV and CX) that will retain their memory for over a month without batteries.

Another very likely cause of your problem is dirty internal contacts. The zebra connector between the CPU and keyboard in fullnut machines is partiularly prone to cause this problem. Also the battery contact assembly. Also caused by spilled gunk on the keyboard traces.