HP Forums
WP34S 956 crashing in wine - Printable Version

+- HP Forums (https://archived.hpcalc.org/museumforum)
+-- Forum: HP Museum Forums (https://archived.hpcalc.org/museumforum/forum-1.html)
+--- Forum: Old HP Forum Archives (https://archived.hpcalc.org/museumforum/forum-2.html)
+--- Thread: WP34S 956 crashing in wine (/thread-184700.html)

WP34S 956 crashing in wine - Neil Hamilton (Ottawa) - 05-25-2011

I updated to 956 this AM and tried to run it up under wine (wine-1.2.2 on ubuntu 10.04) with the following crash. Does anyone know what is going wrong? This has been working beautifully under wine thus far.

(I have removed some of the svn update output and most of the debugger dump for clarity.)


nhamilton@hp-ubuntu:~/Downloads/wp34s$ svn up https://wp34s.svn.sourceforge.net/svnroot/wp34s wp34s_svn
Skipped 'https://wp34s.svn.sourceforge.net/svnroot/wp34s'
U wp34s_svn/trunk/windows/wp34sgui/wp34sgui.vcxproj
U wp34s_svn/trunk/windows/wp34sgui/builddate.h
U wp34s_svn/trunk/windows/wp34sgui/wp34sgui.c
U wp34s_svn/trunk/windows/bin/emulator_d.pdb
U wp34s_svn/trunk/windows/bin/emulator_d.lib
U wp34s_svn/trunk/windows/bin/wp34s_compact.bmp
U wp34s_svn/trunk/windows/bin/emulator_d.dll
U wp34s_svn/trunk/windows/bin/wp34sgui.exe
U wp34s_svn/trunk/windows/bin/emulator_d.exp
U wp34s_svn/trunk/windows/bin/wp34s_medium.bmp
Updated to revision 956.
Summary of conflicts:
Skipped paths: 1
nhamilton@hp-ubuntu:~/Downloads/wp34s$ wine ./wp34s_svn/trunk/windows/bin/wp34sgui.exe &
[1] 1623
nhamilton@hp-ubuntu:~/Downloads/wp34s$ fixme:heap:HeapSetInformation (nil) 1 (nil) 0
wine: Unhandled page fault on read access to 0x0044c000 at address 0x414540 (thread 0009), starting debugger...
Unhandled exception: page fault on read access to 0x0044c000 in 32-bit code (0x00414540).

Re: WP34S 956 crashing in wine - fixed! (?) - Marcus von Cube, Germany - 05-25-2011

What happens if you delete your old state file wp34s.dat?

P.S.: Your SVN command is way to complicated. Just go to the top level directory of the project (wp34s_svn in your case) and type "svn update". SVN knows from the hidden .svn directory what to do.

Edit: I think I know what happened: Your state file was too old and some garbage was interpreted as a length field. I've added a sanity check there but deleting the file will certainly help. It's invalid anyway. If you have a program in your file which you want to save, just forward it to me. I can extract the code for you.

Edited: 25 May 2011, 7:04 a.m. after one or more responses were posted

Re: WP34S 956 crashing in wine - Neil Hamilton (Ottawa) - 05-25-2011

As suggested, I deleted all the copies of wp34s.dat in the tree (there were several so I suspect that it saves this file out to whatever directory I launched from). Still no luck.

I poked around a few other revision to see what would happen. If I wind back to 954 (svn up -r 954), everything works fine. However, 955 crashes in the same manner as 956.

Thanks for the svn wisdom. I'll admit that I am much more familiar with cvs than svn. Your suggestion is certainly much shorter. I was just using what was documented on the sourceforge website (your know: if it ain't broke, ... you're not trying hard enough :-) ).


Re: WP34S 956 crashing in wine - Marcus von Cube, Germany - 05-25-2011

Try 957 and report back.

Re: WP34S 956 crashing in wine - Neil Hamilton (Ottawa) - 05-25-2011

957 works like a charm!