HP Forums
wp34s 1.17 Build 838 SLV - Printable Version

+- HP Forums (https://archived.hpcalc.org/museumforum)
+-- Forum: HP Museum Forums (https://archived.hpcalc.org/museumforum/forum-1.html)
+--- Forum: Old HP Forum Archives (https://archived.hpcalc.org/museumforum/forum-2.html)
+--- Thread: wp34s 1.17 Build 838 SLV (/thread-183777.html)



wp34s 1.17 Build 838 SLV - Norman Dziedzic - 05-07-2011

I tried to solve my inefficient, quadratic program from a while ago and when I do it seems the solver hangs. Works in the emulator but not on 30b hardware.

I put a PSE in the program and I only see one update and then the screen goes blank. Without the PSE the screen shows "Running Program" with the DEG, 360 and = annunciators on steady.


Re: wp34s 1.17 Build 838 SLV - Thomas Radtke - 05-07-2011

In some years, this will be the museum of WP calculators ;-).

I like this project very much, but traffic would justify setting up a newsgroup or mailing list, leaving this space for on-topic discussions.


Re: wp34s 1.17 Build 838 SLV - Marcus von Cube, Germany - 05-07-2011

A separate forum will part us with the expertise of the members of this community which is badly needed for serious progress. Think of wp34s and the corresponding math discussions as an extension to HP's current calculator portfolio. We're still talking typical HP calculator topics, like RPN, the solver, keystroke programming, and the like.

Get your own HP 30b, flash it, and enjoy the progress! :-)


Re: wp34s 1.17 Build 838 SLV - Gerson W. Barbosa - 05-07-2011

I plead to disagree. WP 34s is an hp-20b/30b repurposing project, therefore not off-topic here.


Re: wp34s 1.17 Build 838 SLV - Marcus von Cube, Germany - 05-07-2011

A blank screen is certainly a bug. How do you get the calculator back to life? Do you see the "bye..." message?

Reasons for this behavior may be stack overflow, another memory corruption bug or what ever. Hopefully, Pauli will get back online soon and can join the discussion. His Internet connection is flacky at best.


Re: wp34s 1.17 Build 838 SLV - Norman Dziedzic - 05-07-2011

I can being it back with any of the following:
- batery pull
- reset button with paper clip
- reset button on the programming cable.


Re: wp34s 1.17 Build 838 SLV - Katie Wasserman - 05-07-2011

While I agree that the wp34s is on topic I also agree with Thomas that bug/feature discussions make it difficult to see other topics because of the way threads must be viewed.

Is there some way that the wp34s threads can be encapsulated so as to not be so overwhelming? If Dave Hicks is still "out there" I wonder if he can think of a way to split off a sub-forum on this (and maybe other future topics as well).

-Katie

Edited: 7 May 2011, 11:19 a.m.


Re: wp34s 1.17 Build 838 SLV - Thomas Radtke - 05-07-2011

Quote:
Get your own HP 30b, flash it, and enjoy the progress! :-)

Did so with my 20b.

I remember a time when discussions about new HPs (with original firmware) were considered off topic. I don't mind, but we're now at a point that this forum ist abused for support *at a regular basis*.

Fun in the beginning, highly boring at present. And there's no end in sight.

Don't get me wrong: Great project, but still OT *here* (this is a museums forum).


Re: wp34s 1.17 Build 838 SLV - Don Shepherd - 05-07-2011

Marcus, I certainly agree that 100% of the people you want input from are members of this forum. And while hpmuseum is technically, of course, a "museum", discussions of current (not to mention future) HP calculators are enjoyed by all.

While I'm not particularly interested in this development effort, I know that many are. Katie has suggested some type of "sub-forum" and that would be a good idea. As developers, I would think your team would want a dedicated forum for reporting and tracking bugs, documenting each release, and suggesting enhancements, and it seems to me that this forum is not the ideal venue for that, just from a logistical point-of-view.

You guys have done some very good work, and it is relevant to this community (forum), but I would think a dedicated forum would be more beneficial.


Re: wp34s 1.17 Build 838 SLV - Juergen Keller - 05-07-2011

Quote:
If Dave Hicks is still "out there" I wonder if he can think of a way to split off a sub-forum on this (and maybe other future topics as well).

I second your proposal, that would be a good solution, and is quite common in other forums. But I guess it needs some (substantial?) work on Dave's side.


Re: wp34s 1.17 Build 838 SLV - Marcus von Cube, Germany - 05-07-2011

2 points here:

1/ If Dave can support us with a special forum, I will happily go there for any wp34s stuff. If not, ?

2/ Norm, you must have hit a very nasty bug. I'm trying to find it at the moment but it's very hard work. :-( I report back when I'm done.


Re: wp34s 1.17 Build 838 SLV - Norman Dziedzic - 05-07-2011

I guess someone else should verify that they can duplicate this.

Is anyone else observing problems with this?

And, yes, a forum with subjects would be nice. Of course, much easier for us to say than it is to implement.


Re: wp34s 1.17 Build 838 SLV (should be known as: subdividing the forum) - Walter B - 05-07-2011

Quote:
If Dave Hicks is still "out there" I wonder if he can think of a way to split off a sub-forum on this (and maybe other future topics as well).

I concur as well. One sub-forum for repurposing, one for TAS-related stuff, one for garage sale and thrift store discussions, one for RPL, one for educational topics, one for the 12C, the 71B, the 41Cx, etc. ;-)

IMHO it's a problem of the way threads are organized (here at least) - they tend to branch and twig, change topics (most times without changing the subject), and there are no tools to bring all these together again. So people lose track after a while and start a new topic ... I don't know if it's really beneficial - we once started one thread about the bugs found and we could have kept that all the way with some intermediate statements - new release, all known bugs killed - up to now.

OTOH, we wouldn't face this problem now if HP had kindly followed our repeated plea for a 43S. Ceterum censeo: you know ;-)

Walter

Edited: 7 May 2011, 4:36 p.m.


Re: wp34s 1.17 Build 838 SLV - Marcus von Cube, Germany - 05-07-2011

I see the bug on my system and I have identified the area where the crash occurs, but I'm still fighting. (In fact not at the very moment, I needed a break. ;-) )


Re: wp34s 1.17 Build 838 SLV - Hopefully fixed! - Marcus von Cube, Germany - 05-08-2011

I've reverted to the Yagarto compiler and the bug seems to be gone. Please test!


Re: wp34s 1.17 Build 838 SLV (should be known as: subdividing the forum) - Norman Dziedzic - 05-08-2011

Most other forums that I frequent use pbpBB as their software.
http://www.phpbb.com/

I have no idea what it takes to implement that vs. the current board but I think it would be beneficial to segregate topics a little.


Re: wp34s 1.17 Build 838 SLV - Eddie W. Shore - 05-08-2011

I agree, the wp34s is further continuation of how to modify an HP calculator and has generated a lot of interest. IMO, it belongs in the main forum.


Re: wp34s 1.17 - Another nasty bug fixed - Marcus von Cube, Germany - 05-09-2011

Please download and install the latest version from SF:

http://sourceforge.net/projects/wp34s/files/

I fixed a serious crash in the CONV catalogue.


Re: wp34s 1.18 v875 SLV - Norman Dziedzic - 05-12-2011

There is an intermittent issue with the solver in 1.18 v875 (30b hardware) where the "Program Running" message is not displayed when the solver is active. The top line just displays SLV _ _. The solver still functions and returns an answer.

I haven't found a firm reproducible sequence that does or doesn't show the program running message. However, more often than not, I will not get the "Program Running" message. It seems that if I re-run the solver with identical guesses I will then see the "Program Running" more often but it is not 100%.


Re: wp34s 1.18 v875 SLV - fixed! - Marcus von Cube, Germany - 05-12-2011

Thanks for the hint. We need to look into it. I guess it's a minor issue but it may hide a more serious bug.

Edit: It seemed to be a minor glitch related to power saving. The most recent build contains a fix for this.

Edited: 12 May 2011, 6:19 a.m.


Re: wp34s 1.18 now on revision 884 - Marcus von Cube, Germany - 05-12-2011

I've addressed a few more bugs and rough edges. Get the latest image from SVN.