HP Forums
HP-41 / EMU41P emulator query - Printable Version

+- HP Forums (https://archived.hpcalc.org/museumforum)
+-- Forum: HP Museum Forums (https://archived.hpcalc.org/museumforum/forum-1.html)
+--- Forum: Old HP Forum Archives (https://archived.hpcalc.org/museumforum/forum-2.html)
+--- Thread: HP-41 / EMU41P emulator query (/thread-163713.html)



HP-41 / EMU41P emulator query - John AS (UK) - 03-03-2010

Hi,

I have recently installed the free version of EMU41P (HP-41 emulator) on my HP Portable Plus (has 1MB RAM so should work fine).

I am having problems with ALPHA mode, I am seeing the following:

Key pressed -> Character displayed

A -> a

B -> b

C -> c

Q -> *

W -> *

N -> *

T -> *

H -> *



basically I can only enter lower case abcd, other characters give * (I did see some other special characters, can't remember what I pressed), I can't enter upper case A to Z. I think I have entered some sort of character mode, can anyone suggest how to return to normal? Backspace deletes the * characters as normal.

I can enter commands OK, eg



XEQ ALPHA CAT ALPHA



enters the CAT command.



Regards,

John


Re: HP-41 / EMU41P emulator query - J-F Garnier - 03-03-2010

Hi John,

There is no problem with Emu41p, very likely you loaded the CCD ROM (or the CCD-OSX). Just activate the USER mode to access the normal upper characters in ALPHA mode, see the CCD ROM manual. Or remove the CCD ROM from the emu41.ini file if you are not confortable with it.

J-F


Re: HP-41 / EMU41P emulator query - Ángel Martin - 03-03-2010

Exactly my thoughts. I wish the CCD designers had implemented the reversed arrangement for the lower-case characters (that is activated with USER is ON and not the other way around).

BTW, does anybody (besides Raymond :) have access to a original (read: commented) CCD source code listings?

Best,
'AM


Re: HP-41 / EMU41P emulator query - John AS (UK) - 03-04-2010

Many thanks for the replies, apologies for the basic question I am a HP-41 newbie. This was the first time I tried to use the CCD module, the answer was to press USER (F2 in EMUI41P) to switch User mode on - all working fine now.

I've had a look at the CCD manual, and it explained about the keypad mapping to allow direct entry of any character - very nice. A colleague also added that the HP-41 display cannot show any lower case apart from abcde, hence the ******!


Next (simple) question on the CCD module then - how please do I enter following commands:



CAT'0 - to list HP-IL devices

CAT'7 - to DIR of HP-IL module



I tried:



XEQ ALPHA CAT ALPHA 0 (or 7) but that just listed all the functions.



Regards,

John


Re: HP-41 / EMU41P emulator query - Ángel Martin - 03-04-2010

SHIFT, ENTER, 0

or

SHIFT, ENTER, 7