HP Forums
I got jinxed: Need help from an Mcode/NoV pro - Printable Version

+- HP Forums (https://archived.hpcalc.org/museumforum)
+-- Forum: HP Museum Forums (https://archived.hpcalc.org/museumforum/forum-1.html)
+--- Forum: Old HP Forum Archives (https://archived.hpcalc.org/museumforum/forum-2.html)
+--- Thread: I got jinxed: Need help from an Mcode/NoV pro (/thread-161269.html)

I got jinxed: Need help from an Mcode/NoV pro - Geir Isene - 01-01-2010

So, the newly released ICEBOX.ROM version 1G works nicely under M41. When I try to burn it into my NoV-64, it simply doesn't show up. Nothing is in the specified page (checking with Hexedit, there are only zeros - but the rom file is verifiably not empty as I checked it in a text editor). No errors when running ClonixCfgWin.exe and assembling the HEX image. I have tried to burn my NoV-64 with only the ICEBOX1G in page #C or page #D in either flash block. I tried to burn it together with other rom images. Still the same.

Here is where it's good to have a community like this - I hope there are someone here who can try the new image into their own NoV-32/64 (or MLDL) and check if they get a similar result and if possible give me a pointer to what is wrong with the rom. The rom and the source code are on the ICEBOX page.

Any help is highly appreciated.

Re: I got jinxed: Need help from an Mcode/NoV pro - Vieira, Luiz C. (Brazil) - 01-01-2010

HI, Geir;

I have already downloaded it from your homepage but I have not uploaded it to the MLDL yet. Will do that and post about it ASAP!

In time: I do not have a NoV64, but I would like to know in which page did you load the ICEBOX1G ROM image. Didi you try loading it in lower addresses (8 or 9)? Just a guess. Some modules who access inner functionality seem to work better when first seen by the system.


Luiz (Brazil)

Edited: 1 Jan 2010, 9:08 p.m.

Works with MLDL2000: config listed - Vieira, Luiz C. (Brazil) - 01-02-2010

Hi, Geir;

I loaded the ICEBOX1G.ROM (MLDL2018A, firmware updated) and it listed OK in the HP41. The ROM mapping is like this:

Page#  image
5 HEPAX 1D (4 banks)
8 SRAM (dir empty)
9 SRAM (dir empty)
A Advantage 1D (bank #1
B Advantage 1D (banks #1 & #2)
F MNFR LBLS (David Assembler labels)
The ICEBOX 1G appears accordingly and its functions are listed as well. Because I prefer the block catalog feature, I usually leave regular CCD or the reduced CCD-OSX configured somewhere, and in this particular case, ICEBOX 1G header and its functions show perfectly well.

I tested just two functions for functionality and both worked fine: BLNG? and KALNG?. In time: BLNG? emits a very brief tone that can be suppressed with CF 26. Is it normal? There is no mention to such tone in the manual.

Again, I do not own a NoV64, but I'd ask you to confirm if the NoV64 accepts a functionality available with MLDL2000 configuration: to enable or disable a particular image. Again, I do not know if it is possible in the NoV64.

Hope this helps.



Edited: 2 Jan 2010, 1:01 a.m.

Re: I got jinxed: Need help from an Mcode/NoV pro - Geir Isene - 01-02-2010

I tried the same pages as the ICEBOX version 1F...

Seriously weird.

Re: Works with MLDL2000: config listed - Geir Isene - 01-02-2010

On the BLENG? tone, I will look into it - it's an ineritance from the TOOLBOX.ROM.

Re: I got jinxed: Need help from an Mcode/NoV pro (why: faulty USB stick... duh) - Geir Isene - 01-02-2010

I have to chalk this up to a faulty USB stick... :-(

Extensive testing shows this to be the most likely reason.

Re: I got jinxed: Need help from an Mcode/NoV pro (why: faulty USB stick... duh) - Diego Diaz - 01-04-2010

Hi Geir,

First, Happy New Year and congrats on your ICEBOX job! ;-)

I've checked it on my NoV-64, and runs as expected. (just the functions relative to block swapping within the NoV-64 memory).

It's certainly wierd that the USB connector leads you to such misfunction... eventually it either shouldn'n be able to perform the programming of the module, or failed the verification process.

Good you have it fixed :-) keep on enjoying your toys!!