HP Forums
A serious bug on HP 35s - Printable Version

+- HP Forums (https://archived.hpcalc.org/museumforum)
+-- Forum: HP Museum Forums (https://archived.hpcalc.org/museumforum/forum-1.html)
+--- Forum: Old HP Forum Archives (https://archived.hpcalc.org/museumforum/forum-2.html)
+--- Thread: A serious bug on HP 35s (/thread-125799.html)



A serious bug on HP 35s - Marcel Pelletier - 10-05-2007

First, type in this short program:

A001 LBL A
A002 10
A003 STO I
A004 1
A005 STO(I)
A006 0.01
A007 STO I
A008 VIEW(I)
A009 ISG I
A010 GTO A008
A011 RTN

If you press XEQ A ENTER, you will see the content of the 10 registers create with a zero value. At each stop, you have to press the R/S key...BUT if you want to automate this, enter a PSE instruction after the VIEW(I) like this...

...
A008 VIEW(I)
A009 PSE
...

and now if you press XEQ A ENTER you will see...

(27)=
0.0000
(28)=
0.0000

So it like the count of the register have change!

You view (27) but in fact this is (0)...

So what's up Doc?


Re: A serious bug on HP 35s - Gene Wright - 10-05-2007

Yes, this was reported here and on comp.sys.hp48 over a month ago.

Seems to be a bug to update the value shown for (I) during a VIEW (I) PSE sequence in a program.




Re: A serious bug on HP 35s - Pavneet Arora - 10-06-2007

Quote:
Yes, this was reported here and on comp.sys.hp48 over a month ago.

Is there a published list of HP35S bugs, so that we can avoid them if possible?

Many thanks.


Re: A serious bug on HP 35s - Seth Morabito - 10-06-2007

The list of bugs compiled by Paul Drake has a permanent home here:

http://www.hpmuseum.org/cgi-sys/cgiwrap/hpmuseum/articles.cgi?read=735


Re: A serious bug on HP 35s - Paul Dale - 10-07-2007

Dale not Drake please :-)

- Pauli


Re: A serious bug on HP 35s - Seth Morabito - 10-16-2007

Oops! Sorry about that, Paul!