HP Forums
Problem with alarms (HP 41CX) - Printable Version

+- HP Forums (https://archived.hpcalc.org/museumforum)
+-- Forum: HP Museum Forums (https://archived.hpcalc.org/museumforum/forum-1.html)
+--- Forum: Old HP Forum Archives (https://archived.hpcalc.org/museumforum/forum-2.html)
+--- Thread: Problem with alarms (HP 41CX) (/thread-102140.html)

Problem with alarms (HP 41CX) - Patrick Jamet - 11-07-2006


I bought a HP 41CX recently and I believe that I have a little problem with the alarms because nothing happens when the alarm is due, instead the alarm is only activated when I press ON to shutdown the HP 41.

I set an alarm. Wait. The Calculator is ON. Nothing happens. I press ON and then ding dong... Why?

It has work at a moment, 2 or 3 days ago, but not any more. Maybe, I set or cleared a flag since.

Could you help me ?

Many thanks.


Re: Problem with alarms (HP 41CX) - Patrick Jamet - 11-09-2006


Nobody has an idea of the reason of my problem? Is it a known bug? Thank you.


Re: Problem with alarms (HP 41CX) - Dia C. Tran - 11-09-2006

Your problem seems to be of that a past due alarm. Is it possible that you accidentally set the alarm for a date or time in the past?

Re: Problem with alarms (HP 41CX) - Patrick Jamet - 11-09-2006

Indeed, all my attempts end as if the alarms are past dues. But they are not. I tried a dozen times.

I tried with Y and Z set to zero, or not.

I tried message alarms, control alarms, and conditional alarms. None of them works.

The flags set are: 26, 29, 31, 38, 39, 40.


Re: Problem with alarms (HP 41CX) - Garth Wilson - 11-09-2006

The possibility that you're setting them for a time in the past was a good idea. How are you entering the time? Remeber it's not relative, but time of day. So if it were 10:00 and you want the alarm to activate in a minute and a half at 10:01:30, you enter 10.0130, not .0130 which would have been almost ten hours ago.

E-mail address: wilsonmineszdslextremezcom (replace the z's with @ and . )