HP Forums

Full Version: 9815A - Tape Operation
You're currently viewing a stripped down version of our content. View the full version with proper formatting.

I just finished getting my printer working thanks to some great advice from Tony Duell.

Now, on to testing.

It's pretty easy to figure out how to create and execute a program but using the tape drive is not so obvious.

There are keys that are similar to what is on the 9825 so I figured I have to mark the tape first then use 0 record or 1 record and 0 load and 1 load similar to the 9825 but that does not work.

What is the correct procedure for:
1) initializing a tape
2) writing a program to a tape
3) loading a program from a tape.

By the way, I'm sending for the HP Museum CD but need this now since I'm going to Japan next week and would like to test this before I leave.

Thanks again,

Hmmm... It's been a long time since I've tried this, and I prefer hardware questions, but here goes.
I don't have the user manuals either, but I deduced something from the information on the printer paper flap on my machine. And this is what I remember doing when I tried out my tape drive.
To format a tape : Put the file size (bytes?) in Z, number of files in Y and first file number in X, then press MARK.
To save a program, put the 1st step to save in Y, the file number to save it to in X and press RECORD (I think it goes until it finds 2 STOP lines together or something).
To load a program, put the 1st step to read it to in Y, the file number in X, and press LOAD.
Give that a try, anyway.

I tried the Mark, already before asking this question.

I did exactly like you suggested because I remember the 9825a using mark like mrk 0, 5, 100 or something like that. So, I tried various permutations of that using x, y and z.

But that did not work. The tape drive looked as if it were trying to work. It would advance as if doing something but then I'd get an error like "File Not Found". So rather than Marking, it looked like it was Loading...

The Mark and Load use the same button but mark uses the f^1 key, I guess. I tried various usages of Gold Mark, f^1 Mark, etc and everything produced the same "file not found" printed message.

I have not tried the Record and Load as you suggest but will try, if I can ever get the tape initialized. It is possible that I have a tape problem. But I would expect different error on Mark if there was a hardware problem.

I still think it is operator error on my part.

I feel like that monkey trying to write shakespear play on a typewriter, without a manual:-)

I am 99.9% certain that to get the MARK function you press <gold> <MARK>. Not f-1.
Try something like 1000 <enter> 10 <enter) 1 <MARK> and see what it does. Those values
should be reasonably sane, anyway. Do you know that the gold key on your machine is working
properly (does it work with some of the maths functions on the right side of the keyboard)? It might be something trivial like that!

It works after a lot of playing around. I'm still not sure what the secret was but nothing seem to be quite right with my Marking until I tried the Y paramater that was NEGATIVE.
Then, things started to work a little more correctly. I found that now I was getting "File too small" errors; which was good. At least the firmware was responsive to what I was doing.

Turned out my test marking was with a filesize of 100. I figured a simple 4 line program should fit into that space. But the problem was that I did not end my program with ENDs and it looked to the 9815A like my program was the entire program space, I guess.

After I terminated my programs properly with Ends, the programs would Record and Load properly.


After rethinking my problem, I think it may have turned out to be a combination of things.

First, I was not too sure about the proper commands. It only started working after I performed a Mark command using negative Y value.

I was using Z=size, Y=-5 (quick erase 5 files), X=0 (first step).

But, I forgot that I also cleaned the tape head just before that try. I took another tape and tried it once I figured out the correct command sequence and it seems that it really does not need the negative Y parameter.

The other problem turned out to be that I was testing this with a file size of 100. I figured surely a 5 line program would fit in that space. Turns out that I did not terminate the program with END and the calculator thought my entire program space was the program. Once I used the END properly, I could Mark, Record, and Load programs just fine.