HP Forums

Full Version: HP-35
You're currently viewing a stripped down version of our content. View the full version with proper formatting.

Just purchased a really nice HP-35 on eBay. Received unit, installed new battery pack and hooked up to charger. Checked unit for power up and function when tied to AC and all works fine. Let batteries charge for about 8 hours, unhooked charger and tried running on battery. Unit will not turn on. Swapped charged battery pack from HP-45 and same result. I took a closer look at battery spring terminals and found one with some corrosion. Cleaned up both terminals and tried again... No luck. Looks like something has opened up in the 30 years this guys been on the job. I don't have a multimeter so can't troubleshoot further.

So, here's the question for the experts out there: Can this problem be repaired easily? I would be willing to get the calc repaired provided low probability of collateral damage to other circuit functions.


There is a flexible metal plate that connects the left and right charging posts when the cable of the AC adapter is removed, as you can see in the picture (the contact is made next to the posts bases). Check for bad contact there (no need to open up the calculator).

Complete instructions at the Museum's Repair section:


Good luck!

Edited: 16 Apr 2006, 7:28 p.m.

Thanks for the repair instructions and images. As you suggested, I inspected the metal tabs next to left/right charging posts. Both were tight against the contacts but badly oxidized. Used some emory cloth and cleaned them up. Inserted battery pack and switched on. It works now !!!

I really appreciate your help...