HP Forums

Full Version: HP-86 disk backup
You're currently viewing a stripped down version of our content. View the full version with proper formatting.

I'm trying to get a backup of a 3.5 floppy disk, 720K DD that has a program for the hp-86 on it. I can't seem to initialize a new dd disk on the system though. Whenever I execute the command: INITIALIZE "TEST", ":D700", 13, 7 the red light goes on but the disk never gets finished. It either just sits for a long time and doesn't complete or it spits out this "error 129: medium". I obviously can't make a copy on newer pc's because the file format isn't supported. Does anybody have any idea what I can do to fix this?

You need to use LIFUTILS to be able to read/write an HP-86 floppy on a PC. I don't remember the link.

A 720KB drive is better than a 1.44MB one.


Patrice

On some drives is isn't possible to use format a 'new' 1.44 Mb blank disk as 720Kb as they have a sense switch, this can be defeated by covering the hole opposite the write protect tab with insulating tape (no selotape as this passes light). I know I used this trick a long time ago to allow me to copy some 720Kb disks to 'new' media a long time ago - but I can't remember what type of machine it was on...

Or if it's the HP 86 drive, make sure your disk is *not* HD but a true 720K disk. The HD disks have a higher coercivety oxide than the non-HD versions. Usually the HD drive can format both disk oxide types, but low density drives cannot write the high densitiy disks (not enough write head current, and the density hole is there to tell the drive to up the write current level).

Also, if you write a low density disk in a high density drive, it often cannot be read in low density drives, but will be readable by HD drives.

Sbirdasn.

Well I've pretty much tried everything possible and I still can't get it to format the disk. I tried using the lifutil to format a dd/ 720 k disk and it formatted correctly, but when I try to store a program from the hp-86 to the disk, it throws a disk error. When I try and initialize the same dd/ 720 k disk on the hp-86, either the red light stays on forever or it throws another error. Something to the effect of "Error: medium". I've exhausted pretty much every possible idea. Any other ideas would be great, but I don't think there is much more I can do. I wonder if there is something wrong with the floppy magnetic head reader/writer or something? We can read from disks just fine, just can't seem to write correctly. I've also noticed that you can enter parameters after the "initialize" command. like "initialize ":d700", 12, 04 for the disk size. I've tried many different ones but nothing works. The default initilize command should work anyways. I could really use some help if anyone knows more, thanks!

-Tyson

Since you want to make a copy of an existing disk, why not use LIFUTIL to copy the contents of the original disk to the new disk.

Then you can test to see if the HP-86 can read the copied disk without an error.

BTW what kind of disk drive do you have? Is it the HP 9121D ?

If so, have you tried the right-hand drive?

I have an 9121D with one drive being able only to READ floppies. If you tried to write a floppy, it would think for ever and then report an error (like your drive). I figured that the drive was broken and decided to restrict its use to that of a read-only device.

Since this was originally the left-hand drive, I swapped it with the right-hand drive, and disconnected the WRITE-PROTECT sensor (so that floppies always appear to be write protected). In this way, the system reports the disk as protected rather than waiting for the drive to timeout (faster).

So now the right-hand drive is my guarantied READ-ONLY drive. I can still use the left-hand drive as a normal drive, but when I copy diskettes, I have to use the right-hand drive as the source drive.

**vp