HP Forums

Full Version: HP solver has some bugs
You're currently viewing a stripped down version of our content. View the full version with proper formatting.

try to find a root for 25*x-5*ln(x)=0 using the hp49g solver...

Plot it from x=0 to .5 and tell us what you expect.


Well, it shouldn't return 0.2 something. :-)


"will" --

My 33S also can't find a real root to your equation. I suspect that neither can my 15C, 28C, 32SII, 34C, 41C*/Advantage, 42S, 48G or 49G.

Mike and Gene might be coy, but I think you really meant,

25*x+5*ln(x)=0, for which x = 0.26534

-- KS

Edited: 1 Mar 2005, 12:42 a.m.

My favourite, I posted it below, but NOBODY can tell me, what is the problem in the symbolic solvers!!! Heyhooo Mathematica, Maple, etc programmers!!!! Here is the little problem, what can solve an 10 yrs student, but your 10 yrs old symbolic progs CANT!!!!!

Here it is:

        1            1
3*x + ----- = 15 + -----
(x-5) (x-5)

And the solution is that: "No solution!"

All of softvares gives x=5 that is not root!!!

Feed your head!


True, your function at x=5 is _not_ defined. But (!) the root is a "hebbare Lücke" (sorry, I know only the German word; about "repealable or liftable gap") as the values of the function and its derivative at x=5-0 and x=5+0 are the same. But I am quite sure that no CAS cares about adjacence of gaps in a function.


y=25*x-5*ln(x) has no real solution, whereas y=25*x+5*ln(x) can be solved by HP Solver (tried on 32sii and 40g, solution is 0.2653449...)


Interesting posts...the bug is that the HP solver shows a false answer around 0.2 something which is not a root...in fact there is not real answer...

about the problem that csba told us is quite important avoid divide by 0.


Actually, the solver works perfectly well.
the problem is the user interface which returns 0.2 (and some change) but without displaying the appropriate error/information message: "Extremum"

If you try the "OLD" version of the equation solver UI:
hold red shift, 7, ROOT '25*X-5*LN(X)' ENTER green shift EQ, SOLVR green shift X, you will get 0.2 and change and the message Extremum saying that the solver found an extremum, but not a solution


All one has to do on the new solver is press the menu label "INFO" and it will indicate that the 0.2 was found as an Extremum.

This is ALWAYS a good idea and is proper use of the solver. One should never! accept a numerical result from a solver without knowing this type of additional information.

Always press INFO to find out how the result was obtained!


The problem is that SOLVE starts with the value x=0, and then returns immediately an error message because of the impossibility of ln(0). In this case the SOLVE program on the MATH-1 module for the HP41 works better, since it asks first for two GUESSES for the solution. This way you can avoid the ln(0) by entering 0.1 or something like that. Then the program runs for some seconds and gives the answer ROOT IS 0.265344933.

The manual of the HP32SII has an interesting appendix telling how SOLVE works, and explains some of its limitations.

And let me remind you that EVERY numerical algorithm has its limitations. So is mathematics, sorry.

Aha! HP listens to the grapevine -- Bon jour CdB! :)

Could you pls tell us on which ROM version the "old" UI is available? I tried (i) Version HP49-C, Revision #1.18 (no difference between red-shift 7 and hold-red-shift 7), (ii) Version HP49-B, Revision #1.19-6 (same as i), and (iii) Version HP49-C, Revision #1.24 but there I was not able to reproduce your example. Suppose you are on a HP-49G+plus.

BTW, sorry if I ask for info that is described elswhere and I did not find it: what is the meaning of version letters on the HP49G? It seems not to correspond with the revision numbers. B=Beta and C=produCtion?


Edited: 2 Mar 2005, 9:18 a.m.