HP Forums

Full Version: 15C all functions work, but can't self test
You're currently viewing a stripped down version of our content. View the full version with proper formatting.

I have an old HP 15c that I "inherited" from my uncle.
I'm trying to learn to use it and though it seems to execute all the functions properly, I cannot get it to do the self test or the keyboard test.
Instead of it going into test mode, it just turns on.

I know to hold down the x key, then press the "on" key, then let go of the x key, but no joy.

If anyone could help, I'd appreciate it.

Thank you.


maybe you mixed up the order of keys you have to press/release.

Before initiating the key sequence,

the calc has to be turned off.


1. Press and hold the 'x' key.

2. Press and *release* the 'ON' key.

3. Release the 'x' key.

Now the self test starts. After finishing, all segments are lit.

To return to normal mode, just press any key.



Edited: 27 Aug 2004, 1:51 a.m.

Yes, I'm sure I've done the sequence correctly,
In fact, I just put in a new set of Duracell batteries and tried the test again and it worked like a charm.
However, after getting it to work once, I now cannot get it to do it again!

Very frustrating :/

Thanks for your help though.

Strange as it may sound, chances are you have a bad memory backup capacitor. Take the batteries out for 30 seconds, then put them back in. If you see PR ERROR, you have a bad capacitor. The capacitor should hold memory for at least five minutes so the thirty second test is usually enough to determine if it's a problem.

The value of the part is 22uf but it can be a standard radial leaded electrolytic or a surface mount tantalum - it depends on the age of the unit. I've never seen a tantalum fail, only the standard electrolytics.

Found the problem. I was trying to make it do the test again immediately after a test. If I just let it sit for a minute, it can do the test again perfectly.