HP Forums

Full Version: Re: HP-41C repairs in the UK?
You're currently viewing a stripped down version of our content. View the full version with proper formatting.

Hi Steve,

I haven't heard of anyone in the U.K. repairing HP41s, but Steve Kersey in the US does, and I will give it a go if you want, I am in Australia.

If you are willing to open the calc up, try squirting some circuit board cleaner into the hole behind the switch, then exercising the switch for a while. Get a circuit board cleaner that doesn't leave any residue. I use the "Ultrasolve" product. Opening the calc will also let you see if you have a cracked plastic problem. Both worse case scenarios, broken plastic screw posts, and the switch need replacing are both possible to rectify, but they are both time consuming.

Cheers - John


Thanks for your input. I will attempt what you suggest, but I may chicken out if it looks too difficult.

I shall bear in mind your offer to fix it - you may well be hearing from me!

Regards, Steve

I opened up the calculator, used the cleaner as you suggested, and, hey presto, the calculator works!

However,... the problem now is that only two of the ports work (1 and 3). If I plug an application ROM in port 2 it is ignored. If I plug a ROM in port 4, it causes the calculator to go crazy - sometimes whining, sometimes displaying strange characters, but never working. The calculator is also impossible to switch off with something in port 4. A further issue is that none of my memory modules seem to work in any of the ports, even those where application ROMs seem to work.

So, what to do? I tried cleaning the corrosion off the connections to and from the ports but this had only a temporary positive effect on port 2 (i.e. it worked for about two minutes). Any ideas?