HP Forums

Full Version: oncemore: HP41cv LCD
You're currently viewing a stripped down version of our content. View the full version with proper formatting.

Hi there when i switch my HP41 on some elementa of the characters fade out, especially the upper part of the / in the 0. This happenes to all digits. Bending and tweaking the calc a bit solves the problem for a while. In my experience it was always the contact-rubber between the driver-pcb and the display when i had such problems with various LCDs. How can i get to it in my HP41 ?

Thanks Peter

Carefully remove the feet and there's a screw under each one. Try to ensure the rubber foot and the adhesive don't get separated when you're taking the feet off.

The case just comes apart. Remember which end the longer screws go it (it's pretty obvious). Don't tighten them too much when you do it back up (maybe the problem is that the posts they screw into are already broken??). The U shaped bit that goes between the two halves has a right way and a wrong eway :-)

There are notes somewhere (on this site?) about replacing the connection between the boards with a ribbon cable. Also check the connections to the LCD board. These can come adrift with very strange results.

I had this problem just last week after reassembling a calculator. I thought it was the logic board, but when I replaced it, the problem remained. I then cleaned all contacts between the logic board and the keyboard, and between the keyboard and battery terminals, reassembled, and problem gone. Hope this helps - John