HP Forums

Full Version: hp-11c - display problems
You're currently viewing a stripped down version of our content. View the full version with proper formatting.

Hi folks,
First post for me here, hope you're all ready for Christmas.
But down to the biz at hand.. I've got a couiple problems with my HP-11c, circa 1984;
1. "stuck " in scientific notation
2. prior to that, was not displaying a decimal point.

I tried running the tests -
off, hold down + turn on, release +

off, hold down "division" turn on, release "division"

off, hold down "multiplication" turn on, release "multiplication"

off, hold down "subtraction" turn on, release "subtraction"

Any ideas where to go next?
Stupid question perhaps.. could my batteries be low? I've replaced them within the last 5 years!!


if you want to change from scientific notation to a fixed decimal places' notation, locate the [7] key and you'll see an orange (golden?) FIX over it. Now locate the [f] (orange/golden) key, beside the [ON] key. Now think of how many deciaml places you want: what about 4?

Now press the keys: [f] [7] 4 (think that [f] [7] mean [FIX], O.K.?)

What do you mean for "was not displaying a decimal point"? Does it have a comma instead of a dot as radix mark? If so, do it:

switch the calculator to OFF
press AND hold down the [.] key;
while [.] is down, turn the calculator ON;
release the [.] key

if you repeat this sequence, you'll toggle the radix mark from dot to comma.

Hope this helps.

Thanks for the tip on getting back out of scientific notation.. that worked!!

Let me see if I can describe what I mean about "no decimal point"

I have my decimal fixed at 3 places. When I turn on my calc, I see 0 000 in the display instead of 0.000

I think I'll test my batteries!! :-D


I'm not sure it will solve the problem, mostly because it happens only with the decimal point. If it is a battery problem, all of the LCD's segments would dim off. It's also possible to be a bad contact in the conductive polymer between the LCD and the mainboard.

Anyway, the flashing asterisk is a good indication of low-batteries condition; at least in the Voyagers it is reliable. But testing batteries is harmless and always a good procedure, go ahead.