HP Forums

Full Version: Integral
You're currently viewing a stripped down version of our content. View the full version with proper formatting.

Is there a way to get the integral of 1/(x-1)^2/3 to evaluate as 6?

I get (-3*i*sqrt3 + 3)/2 on the Prime. The NSpire correctly comes with 6.

The Prime froze on a screen...reset hole worked, histories and graph was still there after reset.

The integral is to be evaluated from 0 to 2.

Hello Richard,

from where you got your value of the definite integral with the function 1/(x-1)^(2/3) between 0 and 2?

In my eyes it can't be correct because you integrate over a value x=1, where the function isn't defind.

Is the function you wrote correct written?


Yes, I get the prime result in wolfram alpha ...

I've checked and the Nspire does spit out 6. I beleive this is a result of it being set in "real" only.

Also, ON-SYMB is the key combo to reset. You can always do that first.


Edited: 21 Sept 2013, 4:38 p.m.

Good to know. And to think, along with the Prime, I was going to add a TI N-Spire for comparison. Looks like I can save my finances just buying the Prime instead of both. Thanks for the alert!

Dumb question...how do I do a ON-SYMB ?

Hold both keys down together, release. Equivalent to the ON-F3 on a 50g.

The on-f1-F6 clear memory of the 50g has a similar key sequence with on-apps-esc. It clears out your memory.


The TI seems wrong here.

No freeze for me both with real Prime or emulator

Thanks for the reset instruction...this is preferable to using the reset hole in the back.

Is there a way to get the principal result of 6 for the integral on the Prime?

The graphing and solve apps are really nice! (Can't stand the graphing on the NSpire and all the clutter that results on the plot when finding points of interest)

The function is not defined on |R for x<1

The NSpire result is wrong.

Edited: 21 Sept 2013, 6:38 p.m.

lim with b approaching 1 from below of [3(x-1)^1/3] for 0 to b + lim with c approaching 1 from above of [3(x-1)^1/3] for c to 2

Sorry guys but could you explain me how the result can be complex.....
The primitive doesn't produce any complex value....and if we think as the integral as an area there is no reason, in that particular case, to get a complex value....
Seems to me that (x-1)^(1/3) is well defined in x=1-a a->0....
May be I miss something?
The fact that a function is divergent in some point doesn't mean necessarily that its integral diverges.

My 2 cents


EDIT: I tried with lim a->0'+' instead of a->0 on the Prime : same result

Edited: 21 Sept 2013, 6:50 p.m.

...should add up to 6.

'f(x)=1/(x-1)^2/3' is undefined on |R when x<1

for example

f(0)~= -0.5-0.866i

I don't understand

what is (-1)^(2/3) for you ? A real or a complex number ?

EDIT : If I don(t allow complex

(-1)^(2/3) returns an error in HOME with the Prime :

Error : (X<0)^(not in Z)

Edited: 21 Sept 2013, 7:12 p.m.

>Is there a way to get the principal result of 6 for the integral on the Prime?

I am investigating. :-)


A bit of a paradox!

(-1^2)^1/3 is real

(-1^1/3)^2 is complex.

My 4th edition Heyd Study and Solutions Guide gives this example on page 274 under the topic improper integrals. They used the limits that I showed to yield 6 as the solution.

The Prime doesn't plot below 1, the NSpire shows the whole plot.

Thanks for your interest in this!

Also, (not to sidetrack the integral question), why does the Prime generate a complex result when Complex and i are not checked in CAS setup?

I think we spoke about this in the past and I got a headache :O ;D

The problem is about rational power of negative numbers in R. Seems unclear if it is allowed or not

If it is allowed, the curious thing is that you get a different result in R or C with the same argument.

x in R, z in Q

x^z in R will return one thing
x^z in C will return another thing

Is this correct in a mathematical point of view?

for what I understand,the Prime computes always in Complex domain with the CAS

The CAS setup is not to change the domain from R to C but to allows complex results in variables

Edited: 21 Sept 2013, 8:17 p.m.

Another couple of interesting notes on this problem...in plot mode, if I enter it in as
1/(3rd root (x-1))^2, it plots the whole domain properly, yet, signed area from 0 to 2 comes up as undefined.

In CAS, integral from 0 to 2 of this expression returns itself!

Yet another interesting note...integrating from 0 to 2 1/((x-1)^2)^1/3 yields a choice of 2 answers! A message comes up saying that the exact solution disagreed with the approximate solution, and both will be displayed. When enter is pressed, I get [6 0.]

-> Tim : it seems that in some cases and in 'textbook' mode there are some confusion when you add 2 integrals. Switch to 'algebraic' to see why this 'syntax error'. By the way it works yesterday,perhaps this have to do with some settings... Works fine in algebraic

Edited: 22 Sept 2013, 4:04 a.m.

Sorry, I don't get the point. x^(2/3) is computed as square of cubic root of x then it is defined for x<0 as the cubic root of a negative number in R is defined. And squaring a negative is still in R.
Being -2/3 doesn't change that point.
The fact that complex values are provided is just that in C any cube root provides three results or branches of the function. Then the question is just to define on which branch of the function the integral is defined if the domain is considered C rather R.
Then, 6 is a perfect result in C or R while a complex result is only valid in C assuming the choice of the appropriate branch.

My two cents...

Off the top of my head (so quite possibly I'm completely wrong) I can't think of a single cut in the complex plane that makes x^(1/3) single-valued and real for both real x>0 and real x<0. If the real value is intended for both sections of the integral, perhaps the integral should be split into two parts to make this clear? My sympathies are with the HP Prime on this one - I think that the original integral should give a complex result, unless the contrary is clearly stated.

Nigel (UK)

Integral from 0 to pi of sqrt(1+cos(x)^2) generates a Taylor message, comes up zero. If I force numerical by using 1. in the integral, it comes up with the correct 3.820+ answer.

Interestingly, the NSpire comes up with 4.4418-

Well, if we choose cubic root of x with x<0 as -cubic root abs(x) which means that cubic root of -8 is -2, which is in R then there is no need of any complex value.
The point is that in C cubic root of -1 has 3 possible values:

cos(pi/3)-i.sin(pi/3); -1; cos(pi/3)+i.sin(pi/3)

Then any cubic root of a negative number could be a multiple of those three values.

Depending of the choice the integral will be real or complex. Both results are equally right as long as the hypothesis are clear.

What does the Prime if you plot cubic root of x for x in [-5,5]....?

My two cents...

Ok, I got the answer (and I should have remembered this yesterday).

The CAS always does the calculation in the full plane (as Gilles mentioned below). In order to only evaluate a fractional power in the real plane, the "surd" command is used similar to how mathematica works. http://reference.wolfram.com/mathematica/ref/Surd.html

int(1/surd(x-1,3)^2,x,0,2) spits out the real only root and you get 6.


Yes there can be some confusion here since what actually happens integral(expr,integral(exp)... instead of integral(expr,x)+integral(expr,x). The 2D editor is not completely clear you are still in the d(x) part instead of outside it so it becomes d(x+<next_integral>).

Agreed it needs to be clarified better here and give more visual cue.


I've checked and the Nspire does spit out 6. I beleive this is a result of it being set in "real" only.


You're so generous to your competitor, aren't you? :P :P

Hi Tim,

Regardless of being in CAS or home, I get undefined or errors when I enter the integral in algebraic like you show, or attempt textbook. How are you getting it to work?

My HP Prime Emulator and my nSpire BOTH give [3*i*sqrt(3)+3] /10. What's the problem?