HP Forums

Full Version: wp-34s (Inconsistent Behavior)
You're currently viewing a stripped down version of our content. View the full version with proper formatting.

I noticed an unexpected inconsistency in the Factorial function.

The manual says that Gamma(0) or Factorial(-1) will result in a
"Domain Error". However Factorial(-1) results in a "+ Infinity Error" instead. Taking the Factorial of all other negative whole numbers (-2 .. -whatever) does give a "Domain Error", but
Factorial(-1) is the oddball. Since the Factorial of any negative whole number results in a discontinuous point neither + Infinity or - Infinity, I would think that "Domain Error" would be more correct than "+ Infinity Error". What do you think?

I confirmed this behavior on firmware version 3432 on the real calculator and version 3430 of the emulator. So I don't think it
has been fixed yet.

I noticed another (ODDITY) on the QT Emulator only.
If you have the calculator in FIX 11 display mode
You have Edit Preferences Display Use Real Fonts Checked
You press [2] [+/-] [Enter] [Green] [!]

The Domain Error appears, but the trailing zeros from the underlying
-2.000000000 still appear after Resulting in "Error0000000"
in the number part of the display.

I confirmed that ln(0000000000000) does the same thing as well as
tan(90.000000000) in degrees mode etc. It seems that most errors
don't clear the filled number part of the display before overwriting
with the word "Error".

If you uncheck "Edit Preferences Display Use Real Fonts" or use
the real calculator this problem does not occur only in the QT
Emulator with Real Fonts.


Edited: 22 July 2013, 9:15 p.m.

The +ve infinite result is a bug. I've fixed this now and it will be part of the next build.

Can't help with the emulator display however.


- Pauli

I've uploaded a new build to SVN.