HP Forums

Full Version: wp34s flashing with linux.
You're currently viewing a stripped down version of our content. View the full version with proper formatting.


I am encountering problems when I try to flash my 30B:

I have installed Harald's USB adapter (with LiIon support) but have not yet installed the battery and currently there are no coin cells in the 30B either.
I am using Ubuntu 12.10 32bit.

Every time I try to flash my calculator the wp34sFlashTool gives me an error message: Cannot open serial port.

I also tried using Samba for Linux but it does not work.

I don't think that I have any wrong connection on my calculator because it would connect to the USB-board and then display some sort of other error?

Could anyone suggest what I am doing wrong?

Please install a power supply! You can't expect your calc running on nothing ...


Apparently when running the FlashTool you have to have SU-Rights.

After running the FlashTool as root I managed to flash my calculator. :)

It depends what right you need to have access to the serial port device. More a Linux configuration problem I would say.
Anyway, if it worked, everything is fine.

With the Li-Ion board that should work. But as soon as you unplug the USB the calculator will shut down of course. I wouldn't recommend this though,

Good to hear it worked. I never managed to flash the WP34s using linux. Maybe I have the same problem. I will try this when I get back home.

? The USB adapter normally supplies the power needed, coming from pc or laptop or the like.

Edited: 15 May 2013, 2:24 p.m.