HP Forums

Full Version: Update of Emu71 to v1.03
You're currently viewing a stripped down version of our content. View the full version with proper formatting.

Emu71 v1.03 is available at http://hp.giesselink.com.

Changes to v1.03:

  • improved execution speed of KML "Scancode" command in some situations
  • changed "Locale" KML command (in difference to Emu28 and Emu42 the Locale now reference to the keyboard layout and not to the keyboard input locale any more, this allows now i.e German-German as keyboard input locale but a Swiss keyboard layout)
  • expanded "Single Instance" option to 2nd generation, now the name of the state file of the caller instance is send to the running instance
  • fixed a silly bug at port configuration preventing the configuration of ROM images using an odd number of chips (i.e. JPC ROM rev. E with 48KB = 3 chips * 16KB)

Thank you very much! I only wonder why BEEP isn't working (Sound: Wave, flag -2 clear and flag -25 set). Well, the beeper doesn't work on my physical HP-71B either, so no problem :-)

I only wonder why BEEP isn't working (Sound: Wave, flag -2 clear and flag -25 set).

My emulators cannot emulate the beepers over the OUT opcode because of speed reasons. The only way is patching the ROM, decode the arguments (frequency & duration) and call a PC internal beeper routine.

In the delivered KML files "REAL71BM.KML" and "REAL71BL.KML" the ROM patch for beeping is disabled.

Remove in the Global section the '#' in the line

#       Patch    "BEEP.71B"
        Patch    "BEEP.71B"

and beeping should work. The flags -2 and -25 are ignored in the current version, the beeper is always on. The next version of Emu71 will watch the flag -2 (BEEP ON/OFF).

This has worked, thanks! Now to fix my physical unit one of these days.

What? You mean having it working in simulation hasn't shamed the real unit into working?

Looks like it's totally shameless - still not a sound after hearing the loud noise of its virtual sibling...
I opened it once and resoldered the buzzer wires and it did beep for a while, but then got mute again. As the soldering iron I used in the occasion was not appropriate for the task, I didn't proceed any further lest I damaged it.

It has shamed me into fixing it. Happily beeping now. It turns out it was due to a discontinuity in the inductor wiring, next to one of the leads. Is there an updated service manual? The motherboard in my HP-71B is slightly different.