HP Forums

Full Version: [41CL] Trouble compiling CLWriter.cs
You're currently viewing a stripped down version of our content. View the full version with proper formatting.

I have the correct version of .NET on my device it appears, and I execute this command:

C:\WINDOWS\Microsoft.NET\Framework\v4.0.30319\csc.exe /t:exe CLWriter.cs

The compiler starts, but it outputs the following error message:

"CLWriter.cs(3,17): error CS0234: The type or namespace name 'Ports' does not exist in the namespace 'System.IO' (are you missing an assembly reference?)"

Any help on getting a compiled version of CLWriter.exe?

Hello Dan,

I just tried it with Visual C# 2008 Express Edition (.NET 3.5) and it's working.

I have created a solution called CLTools and inside it I have created 2 projects
one for CLReader and one for CLWriter.

They both compile and execute correctly.

I also tried the following command lines ...

C:\WINDOWS\Microsoft.NET\Framework\v3.5\csc.exe /t:exe CLReader.cs

C:\WINDOWS\Microsoft.NET\Framework\v3.5\csc.exe /t:exe CLWriter.cs

They both compile and execute correctly.

I also tried you're command lines and I got the same error as you.

So we are both missing the Ports library of the .net 4.0 framework.

I have checked the online .net framework documentation and it's still supported.

So we just need to find/download/install the missing library.

I will get back to you when I have found it

Best regards


Edited: 16 Feb 2013, 8:10 p.m.

Found it!

Microsoft .NET Framework 4 (Standalone Installer)


a) download the installer file

b) run the installer

c) do a windows update

d) reboot

e) retry your command and it should work (it worked on mine)

Best regards,


Edited: 16 Feb 2013, 9:36 p.m.

Thank you! I got the download to work! I can now use the serial port to update my -41CL!