HP Forums

Full Version: Flashing the DM-15CC
You're currently viewing a stripped down version of our content. View the full version with proper formatting.

Hi and happy new year.

Left Hong Kong on January 1st, 2013 at 8pm and arrived in Vancouver at 8pm on December 31, 2012.

Felt like Dr Who... ;-)

Any how, was trying to flash the DM-15CC using Flashmagic and the CP2102 driver (installed of course).

Followed the instructions to the letter:

link to instructions

I get the following message on the calc LCD:


and the following windows message:

"Failed to read the device signature (Operation Failed, (reading Signature)) Accessing the drive using the wrong signature could render the device unusable."

My system is Windows XP and com 3 which is available.

any ideas?


Left Hong Kong on January 1st, 2013 at 8pm and arrived in Vancouver at 8pm on December 31, 2012.

Felt like Dr Who... ;-)

WOW, you really must be Dr. Who. Or how did you manage to make the journey in -8 hours?!?

Sorry I can't help you with your problem.


Since the first production batch, the chip has changed.

Any chance you have a calculator from the first batches ?

If yes, the chip to setup in Flash magic is LPC114/302

If you have the latest model, I have no further idea.




I had exactly the same issue, which turned out to be dated flashing instructions in my case - I think they've upgraded the processor to a different model.

I wound up opening the calculator, reading the processor type off the chip label and selecting that from the menu.


Edit: As stated by Etienne, above, while I dawdled with my reply :-)

Edited: 2 Jan 2013, 6:24 p.m.

your right, after all these years, that damn dateline!!

Left December 31st at 2100, 3 hours later in Hong Kong it was January 1st. We crossed the dateline 6 hours after departure, so we had 3 hours of January 1st before we crossed the dateline heading east. Once across we were back to December 31st again. Arrived in Vancouver at 1800 on the 31st of December.

Had to really think about that one!!!


still felt like dr who in any case.

yep, the first batch that i have is LPC1114F/302 which is 1114/302 in Flash magic

I will give it a try after dinner and post.

The titanium model gives the same error message and I have not opened it up yet.

Cheers, Geoff

I had the same problem with my DM-15CC (2nd batch). Also on a XP system.

To verify the USB interface hardware of the DM-15CC and the CP2102 driver installation I called the serial console [ON]+[C]. The console worked propely in connection with the DM-15CC. Second I tried to update a DM-16CC on the same computer, which also worked properly. So it was clear that my system was ok.

Then I contacted Michael Steinmann and he told me, that some devices have had problems with the solder connection of the PGM button. With a binocular loupe was was able to verify a cold solder connection at one pin of the PGM button. I fixed this with a soldering iron and then I was able to update the firmware.


Edited: 2 Jan 2013, 7:37 p.m.


I'm a new DM15CC owner. I changed it for an old TI-92(Simple) calculator.

I can't make a ROM dump with it.

I installed the USB driver. The Windows 7 system detected the DM-15CC and attacted it to the USB driver.
I installed the PuTTY.exe too. Settings to the COM 3 port: Speed: 38400 baud, Data bits: 8, Stop bits: 1, Parity: None, Flow control: XON/XOFF.
I turned the connected calculator to Serial Console mode and nothing happened, the empty screen only. I tried the Javascript ROM dump prg too from the Michael Steinmann's site.

Maybe I must repare the PGM button's connection too?


Edited: 13 Jan 2013, 8:39 a.m.

There's no java ROM dump script on the SwissMicros side, but I'm sure that there's a program for a "RAM" ! dump of a DM-15CC memory. The RAM dump mode is accessable over the serial console mode by [ON]+[C].

The PGM button is only necessary for a firmware update.

Finally read the instructions on the SwissMicros page carefully, I'm sure the page tell "set terminal program to 38400,8n1 (no flow control)" and nothing about XON/XOFF as control flow.


There's no java ROM dump script on the SwissMicros side

Not there? Somewhere else??