HP Forums

Full Version: New HP-82240B emulator in WP34s distribution
You're currently viewing a stripped down version of our content. View the full version with proper formatting.

Hi,

I've wrote a multi-platform HP-82240B emulator and it is now part of the WP-34s distribution, i.e. the files in Emulator on SourceForge.

It is a very simple program, not fully tested. So I'm waiting for feedbacks.

Have fun.

Hi Pascal,

Very nice - it works really well with the QtEmulator.

It also sort of work with the Hp-based Emulator - however dumping a large program causes garbage to be printed every ten lines or so. Is the protocol slightly different?

cheers!

This was a first release and some bugs where found including the one you noticed.

I've uploaded a new release which should fix most of them. Let me know.

Much better than the version from Sunday. Displaying characters >= 128 work now. A first test with switching between Roman8 and ECMA94 was successful.

The underlining has the wrong position, the underlining belong to the bottom line of the character and it isn't an extra line.

The expanded character font is wrong. At an expanded character all font columns are printed twice.

The reset command seem to work correctly.

Too long printer lines are clipped instead of correctly continue printing in the next line.

Now I see graphic, but still see displaying problems in form of empty lines with the PRLCD command on the HP48(SX) but _not_ with the PRLCD command on the HP28S.

Christoph

I'll fix these bugs. Most of them come from my lack of knowledge of 82240B behavior and time to test it.

When it comes to graphics, I might need an example to reproduce it.

Thanks for helping.

Quote:
The underlining has the wrong position, the underlining belong to the bottom line of the character and it isn't an extra line.

The expanded character font is wrong. At an expanded character all font columns are printed twice.


Too long printer lines are clipped instead of correctly continue printing in the next line.

Now I see graphic, but still see displaying problems in form of empty lines with the PRLCD command on the HP48(SX) but _not_ with the PRLCD command on the HP28S.


I've uploaded a new version and it should fix these bugs. Let me know.

Just made a quick test, problems seem to be fixed now.

TNX,

Christoph