HP Forums

Full Version: HP32SII takes 120 to process a command
You're currently viewing a stripped down version of our content. View the full version with proper formatting.

I'm trying to repair a HP32SII. When I opened it up I discovered someone else had been there before me and it is pretty banged up.

Anyway I did get it going but it is behaving strangely.

1) It will not run any of the self tests.

2) I've tried every kind of reset including removing the batteries and shorting the contacts (and discharging the capacitor).

3) Okay, I press say, 1,2,3,4 5,6 (normal display) then press ENTER
the display shows 'ENTER' for 120 seconds and then the number 123,456 is displayed. I press SQRT and the display shows 'SQRT' for 120 seconds and then the display shows the square root of 123,456. This is pretty much what happens with all command keys. If I press <- there is no delay. Even shutting the calc off takes 120 secs as does STO.

Any ideas?

I'd be very wary of these 'home job' repair acquisitions (especially ones gotten from auction sites). I know that someone here can cure the 32II. I hope all goes well.

Best regards

Well I discovered what was causing this. I took a HP32S I had handy and tried holding down a key while operating it and it produced exactly the same symptoms. So I washed out the HP32SII keyboard and if fixed it.