HP Forums

Full Version: Link for SAMBA v2.10 download
You're currently viewing a stripped down version of our content. View the full version with proper formatting.

I cannot get SAMBA v2.11 to work. AMTEL no longer has v2.10 on their web site. Can somebody post a like for downloading SAMBA v2.10?

Thanks in advance


Edited: 29 May 2012, 2:04 a.m. after one or more responses were posted

Thanks, but that link did not work. Reported error 404

Oops. I tried again and it did work. Thanks

Why do you want to run SAM-BA instead of MySamba?

I have tried Mysamba with no success.

This was my first attempt at flashing my WP34S to load the new 3.1 image. I am using Windows 7 and I tried SAMBA 2.11 since it was targeted for Windows 7. I am using Eric's cable with an FTDI adapter. After installing the FTDI drivers and a few atttempts at finding the right keystrokes and ERASE RESET commands to prep the HP-30B I got it to connect. I pointed SAMBA at the correct file and selected the proper board. When I tried to send the file, the dialog box indicated only 1% of the file transferred and it showed "NO BOARD" on the bottom right of the box. Evidently, I could not get SAMBA to recognize the board or to accept the setting for the board.

Since then I cannot get anything to connect to the calculator. I have tried Mysamba (with XP SP2 compatibility), and now SAMBA 2.10 with no luck. I have installed new batteries and checked that Windows show the drivers. The blue lights on the cable do blink a few times, but all I get is connect failed messages.

So, I have a dead HP-30B and can't get it flashed.


Have you tried pressing reset on the cable, then ON on the calculator and then flashing?
That should work. MySAMBA is usually the easiest and quickest way to do this.
Good luck!

PS: The calculator may appear dead, but it most likely is not. You just need to find out what you are doing wrong in the flash process.

1) new batteries
RESET on cable
ON on HP-30B
Blue LED flashes 3 times
2) RESET on back of calculator
Blue LED flashes 3 times

After you have tried MySamba you will definitely need to do an ERASE again. MySambe set the boot bit first and then satrts the flashing process. If the latter fails, the firmware is flashed half way but the boot bit is set to start this broken image. ERASE will clear all flash and set the boot to SAM-BA.

Thanks for the quick response Marcus.

I tried various combination of RESET EERASE and ON with no success. The blue LED flashes 3 times and then the NO CONNECT message appears.