HP Forums

Full Version: 200LX -- can't seem to access A: drive
You're currently viewing a stripped down version of our content. View the full version with proper formatting.

Hi All --

I recently won an HP 200LX on TAS. Seems to be in nice condition and fires up well; however, I purchased a 64mb Compact Flash card and adapter from the Palmtoppaper site so that I could put a few other applications on the device ... and I can't seem to get the thing to access the A: drive at all. I've put the card in numerous times and rebooted, only to get the "Not ready reading drive A Abort, Retry, Fail?" message.

I've successfully put things *onto* the card via my laptop (a Linux box); I've tried re-formatting the card ... and nothing seems to work. So I'm thinking it is either the card adapter or something inside the 200LX (I confess I attempted to push the card in upside down the first time I tried it ... maybe I damaged some of the connector pins?)

Just thought I'd post and ask whether anyone had experience with these units or might know something I could try in the way of troubleshooting.



have a look at acecard3.com I needed that driver to access larger flash disk on the 200lx and 95lx


The latest CF cards may not work. I use a PMCIA Type II adapter and a SunDisk 256MB CF card. There's a comprehensive table of compatible cards at http://www.hermocom.com/en/knowledgebase/hplx/storagecards



A 256 mb card will take a long time to be read by the system and which may be too slow to be effective. I use 16 and 32 meg cards with good results. In my experience the cards must first be "FDISK"ed and then formatted using the 200lx. Good Luck

Hi Glenn,

I've used a number of CF cards on the HP-200lX. I've also used some Sony Memory Sticks successfully. I have been unable to get a SD card with a CF adapter to work on it.

I just did a check with a 128 mb card. Worked fine. I then reformated it FAT32 on a windows machine, then I get the error you got. Reformated to FAT on a windows machine, and now get an I/O ERROR on A Drive.

At this point, reformating the card on the HP-200LX and card again works fine. Be prepaired to wait a fairly long time for the format of a large card on the 200LX. (ie, fresh batteries should be installed or a/c adapter).

Check to make sure you have formated it in FAT format. You may want to check the Partition type on the card to make sure it is set for a PC and not linux partition. Suggest you do a format on a windows machine, if you have access to one and then give it another try.

If all else fails, try a different card.

I agree woth others who say staying with smaller cardes is faster. The problem today is finding smaller cards. But you should be able to fdisk a small partition on a larger card and then use it. I haven't tried that, but should work.


you would really have to try to push either the PCMCIA card or the CF card in upside down far enough for them to make contact. Both are made with mechanical to prevent upside down insertion. I have successfully used a 16MB and a 32MB CF card in my 200LX with both FAT12 and FAT16 formats, however like you when I try to initialize a card under Linux or windows I am unable to read the card on the 200LX, however if I format the card in my DSLR I am able to read it on the 200LX.

I started poking around a bit on the 200LX and found a program fdisk100.exe and it allowed me to partition a 85MB Sandisk PCMCIA card I have and and then format it. To have enough memory available to format the card I had to stop everything by going to "More" and then press "MENU" "A" then "T" to terminate all application and drop into DOS, to return to the normal environment type '200'. The format is quite slow but when it finished I was able to copy files to the card.

The manual says to format a card go to Filer then press "MENU" "O" "C" and then you are prompted if you want to format, if you get "format not supported" message then drop to DOS and run fdisk100 to create a partition it understands. I did this with a CF card that I purposely formatted so that the 200LX would not understand it and when it finished formatting I was able to use the card.

Edited: 8 Apr 2012, 11:05 p.m.

Thanks all for the responses, folks.

I actually got the device to recognize the card sufficiently to run DOS 'format' on it, and this seemed to fix the issue.

I think this was a case of not tinkering enough -- of getting frustrated and posting before I should have ...

Thanks again.