HP Forums

Full Version: WP34s -- not turning on after flash
You're currently viewing a stripped down version of our content. View the full version with proper formatting.

I have flashed the 30b several times, but now it will not turn on after a flash. I got all the correct messages, set boot from flash, execute, cable reset, on button : blank screen.

I also went through the entire erase procedure from scratch and same thing happens.

Any suggestions?

did you try popping the batteries out and back in again?

Last time I tried to flash, I got the same thing. I remembered something Neil had told me that sometimes the calculator will appear to be dead but actually still be on at full power. So the recommendation was to pop the batteries out if I was going leave the calculator for a while.

Anyhow, I did this, and when I put the batteries back in it turned on properly!

Yeah, tried that.. will try again...

the corollary to that is that if you didn't pop the batteries out immediately they may be dead.

Maybe I've uploaded a binary that does not work so try the V21 install if in doubt.

Still no go. Everything appears normal in the flash process. It just won't turn on.

David, try MySamba.exe, please! Can yo reflash your calculator with the original 20b firmware?

Can you provide a link to the MySamba.exe program?

I don't have the original 30b firmware to try.

David

Problem resolved!

Thank you Marcus, Gene, Dominic, and Jeff!

The problem was that when I downloaded calc.bin I right clicked and "save link as" on the calc.bin file. The resulting file was only 8k in size. The correct file would be ~121k. This 8k file would give the appearance of flashing but obviously would not work.

The proper method of downloading from the SVN page is to double-click the calc.bin file then select the download link.

It is interesting that even flashing the correct file did not solve the problem. I had to flash the original 30b rom back into the unit and then reflash with the WP34s rom. The unit worked just fine after that.

Also the lead to use MySamba.exe was very helpful, it is much easier to use and very fast.

Wonderful support from all you guys. What a joy. Thank you!

David

oh yeah, I had forgotten that I had done that too once. The clue for me was that SAM-BA wasn't doing 14 or 15 segments, only 1.