HP Forums

Full Version: WP34S: ALL n mode
You're currently viewing a stripped down version of our content. View the full version with proper formatting.

I've noticed the following while using the ALL n mode with rev. 1324:

  1. When in mode ALL n (n#0), at power ON the number in X is displayed in mode ALL 0. Any key press restores the ALL n mode.
    Exemple:
    h ALL 4 3 1/x EEX 3 /
    Display shows: 0.00033333333
    g OFF ON
    Display shows: 3.33333333333 E-4
    Press a key (f, g, h STO or RCL)
    Display shows: 0.00033333333


  2. Not all numbers are displayed the same way under ALL n (n#0).

    Exemple:
    h ALL 3 3 1/x EEX 3 /
    Display shows: 3.33333333333 E-4
    3.33 EEX 4 +/- ENTER
    Display shows: 0.000333 instead of 3.33 E-4

Quote:
When in mode ALL n (n#0), at power ON the number in X is displayed in mode ALL 0. Any key press restores the ALL n mode.

Seems like a bug :-(

Quote:
Not all numbers are displayed the same way under ALL n (n#0).

By design. If all digits fit on the screen in a fixed like mode, they will be shown as such. ALL has always worked this way. Our ALL is simple less aggressive about switching to scientific mode base on the argument.

- Pauli

Edited: 28 July 2011, 3:10 a.m.

Quote:
By design. If all digits fit on the screen in a fixed like mode, they will be show as such. ALL has always worked this way. Our ALL is simple less aggressive about switching to scientific mode base on the argument.

- Pauli


A bug in the manual ? ;-) The manual says:
For x > 10^13 or x < 10^n, display will switch to SCI
or ENG with the maximum number of digits displayable
(see SCIOVR and ENGOVR).
so according to the manual 3.33 E-4 should be displayed in SCI or ENG mode under ALL 3 mode.

Sounds like a problem with the manual.

ALL mode has always stayed in FIX if all the digits fit the display.
That is what this is doing.


- Pauli

Quote:
When in mode ALL n (n#0), at power ON the number in X is displayed in mode ALL 0. Any key press restores the ALL n mode.

It was a bug which had to do with some uninitialized data. Thanks for pointing it out. It's fixed and rebuilt.

Edited: 28 July 2011, 6:50 a.m.

Kudos to the WP-34S team (Pauli, Walter and Marcus) !!!

I'm amazed by your responsiveness and how fast you implement changes: bug fix or new features such as DELp. And the manual is kept up to date at the same pace, I just downloaded the latest revision (1357) and the description for ALL has been updated and DELp is already in :-)