HP Forums

Full Version: HP-67 not displaying decimal point
You're currently viewing a stripped down version of our content. View the full version with proper formatting.

Hi all!

I'm restoring/repairing an HP-67 for a friend.

It took me a long time to find the proper parts and I have restored the card reader, the battery contacts, found a perfect keyboard with non-yellowish keys.

It now works fine except for one thing: the decimal point does not display.

That is all digits display perfectly, calculations, programming... are fine except the decimal point that should light and doesn't!!

Logic board is Ok.

I would like to repair it if possible instead of swapping the display subassembly because I use the Bendix Hp-67 as a base and it has a very complex internal wiring to a specific connector (I've posted pics here a couple of months ago)

Does anybody have a hint ?

Many thanks in advance!

Etienne

Hi all,

Me again.

I've solved the problem.

One of the Bendix connector wires had an unwanted connection to the display driver.

The decimal point is back !

Thanks

Next week-end, I'll try to post a couple of picture of the internals.

Etienne

Etienne,

by solving the problem by yourself, you've spoiled our party! We would have been so happy to help you locating the problem ...
;-)

I'm looking forward to your pictures!

Best Regards,
Juergen

Hello J├╝rgen !

Don't worry, I still have problems with the Bendix-67 :-)

Mainly a weird behaviour during calls to LBLs A to E (programming them is Ok, calling them is not).

As I don't know if this is related to this particular customized calculator, I'll let it to rest for this week and try again in a couple of days.

It's been 8 hours and 2 sushi meals since I started the repair.

Even if it's not my first 67 repair, I proceed more cautiously with this one as I don't want to break the custom connectors all linked to the card reader.

Instead, I'll post the first pictures in a couple of minutes.

Cheers to all !

Etienne