HP Forums

Full Version: De-allocating memory locations on HP-35s
You're currently viewing a stripped down version of our content. View the full version with proper formatting.

Hi!

I'm getting acquainted with my new 35s and finding the transition from my daily driver, a 20s, pleasant; and the return to RPN very refreshing! I won a 41CX in a college design contest in 1989 and became hooked on HP. I do miss that calculator...

While getting to know my new 35s, I allocated the full 801 variable locations with indirect (i). I thought this was fine until I discovered the hard way, (memory full), that the amount of memory left for programming was trivially small. A calculator reset solved the problem but subsequent reading, plus trial and error, has not turned up a way to de-allocate memory once its assigned to variables.

Any ideas from those who understand this better than me?

Thanks so much! Great fourm,

Paul

The memory is dynamic - the more "storage" - the less "program" memory; so you should allocate only the number of storage registers you really need. To release memory taken by no longer used registers store zeros in them; the last not-zeroed one draws the border.

It's all clearly explained in the manual.
cheers

Well,

It's clearly explained in the manual, yet I couldn't get it to release memory. I thought perhaps there was a non-zero value at 801 but it turned out that they were all set to zero.

I suspect it doesn't actually work as the manual says it should.

I don't have my manual handy, from memory it all worked; there are a few quirks with the calculator and the manual - all available through this forum - google it for HP-35S bugs

Or go to the HP35s bugs article.

- Pauli

Press RightShift-Clear, then pick CLVARx (item 6). You'll be asked for a number; this is the highest numbered variable that you want to keep. Every indirect register past that number will be wiped/deallocated.

Dave Britten,

Wow! It works!! and so easily. Thank you for pointing out the obvious that I had missed.

Quote:
Or go to the HP35s bugs article.

- Pauli


Pauli - I want to add another small bugette to your post but I don't want to edit your post directly so if you agree with this one, could you add it please?

In most HPs, if you want to enter 10^6 for example, you just press E or EEX then 6. With the 35s, you have to enter 1 then E and 6 which adds an extra keystroke and shouldn't be necessary. It also adds inconsistency with nearly all HPs from the Voyagers onwards.

I tried this out on a few LCD HPs at random and the only one that needed the 1 was the 19B which otherwise took the E to be part of an alpha message so went into alpha edit mode.

Small but lots of small things add up!

Mark