HP Forums

Full Version: Troubles connencting Conn4x <--> HP48G
You're currently viewing a stripped down version of our content. View the full version with proper formatting.

I am having troubles connecting my HP48G to the Conn4x version 2.3 build 2439. I try to install the XModem library, but I get the error message "The connectivity kit is unable to open communications to COM1".

I do know that the COM-port is ok since I can use my plotter.

Any help appreciated.

TIA Matti

Assuming you are using a serial (not USB) cable to connect the HP48G to the PC com port, check the following:

1) Both calc and Conn4x are set for 9600 baud, no parity (0), checksum CRC (3), no translation (0) and binary transmission.

2) Windows has not allocated the com port to another device, such as a modem. Look into Windows Device Manager to see port allocations. Use AUTO in Conn4x to find a free com port and make sure you are physically connected to it. Com1 = Com3 and Com2 = Com4.

However, I have personally never tried to do this, so it may not be possible.

Good luck,


Hi Michael,

thanks for the reply, but unfortunately it doesn´t quite work out. I had this problem earlier, and cannot remember what on earth I did to get the XModem into my 48G...

In the mean time I connected my 50g to the PC, that went well.

Well still trying...



If you previously downloaded XModem into your HP48G, then it should still be there. It is a library of commands that you attach in the HP48G. See the help topic "XModem Library" in Conn4x. You need to run XModem on the calc before it will connect to the PC.

Also, if you have an HP50G, you can connect it to the HP48G via serial cable, and transfer the XModem library from the HP50G to the HP48G using Kermit. You can get the serial cable for the HP50G from:

HP50G Serial RS232 Cable


Hi Michael,

Well I had it on the calc, but managed to get a mem-lost. So now I do not have it.

As I live in Sweden it´s actually not really an option to buy a 50g<-->48g cable.

As I recall, I made several attempts with no success until I managed to get the download to work.

As I try it right now:
1. Connect the two together with the PC-cable to COM1.
2. Set IOPAR to {9600 0 0 0 3 1}
3. Set the baud rate on the Conn to 9600, and parities to match.
4. I try to launch the command on the PC by File->Download HP48Server (manual XRECV)
=> Error(The connectivity kit is unable to open communications to COM1 [or Auto])

I have no modems, and the COM port seems to work fine, as device manager tells.

And the search goes on... /Matti

"The connectivity kit is unable to open communications to COM1".

Is COM1 visible under the device manager?

If you use COM1 with something else, is that something else running? If so it could block conn4x from using the COM port. I have not worked with serial printers on Windows so I do not know how to tell Windows to release the COM port so that something else can use it.

I solved the problem eventually.
As pointed out I did have a conflict with the port, COM1, so I just put the plotter on another comport, and - dadaaa - I was able to connect.

Thanks for the help!