HP Forums

Full Version: Compiling Nonpareil
You're currently viewing a stripped down version of our content. View the full version with proper formatting.

Hi Eric,

I've just downloaded Nonpareil and want to compile it under Ubuntu on my Eee PC, but I get a missing library error:


marcus@eeepc:/media/sdcard/2/projekte/nonpareil-0.78$ scons
scons: Reading SConscript files ...
Package gtk+-2.0 was not found in the pkg-config search path.
Perhaps you should add the directory containing `gtk+-2.0.pc'
to the PKG_CONFIG_PATH environment variable
No package 'gtk+-2.0' found
...
All libs seem to be missing. I can see the respective .so files in /usr/lib, but the requested .pc files aren't there. Can you direct me a little?

Marcus

If you were running Fedora, I'd say that you probably need the various "-devel" packages. Perhaps Ubuntu also has development packages?

The missing Software should be inside libgtk2.0-dev. Just do a apt-get install libgtk2.0-dev.

OK, after installing a bunch of -dev packages, flex and bison, I still get errors:


gcc -o build/posix/csim.o -c -Wall -g -pthread -D_GNU_SOURCE=1
-D_REENTRANT "-D{'DEFAULT_PATH': '/usr/local/lib/nonpareil'}"
-Ibuild/posix -Isrc -Ibuild/common -I/usr/include/gtk-2.0
-I/usr/lib/gtk-2.0/include -I/usr/include/atk-1.0
-I/usr/include/cairo -I/usr/include/pango-1.0
-I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include
-I/usr/include/freetype2 -I/usr/include/libpng12
-I/usr/include/pixman-1 -I/usr/include/libxml2
-I/usr/include/SDL src/csim.c
<command-line>: error: macro names must be identifiers
scons: *** [build/posix/csim.o] Error 1
scons: building terminated because of errors.

Looks like GCC doesn't like the following: -D{'DEFAULT_PATH': '/usr/local/lib/nonpareil'}

:(

Marcus

No one there to help me? Can I patch the build scripts myself?

Looks like you're using a newer version of SCons than was supported by that release of Nonpareil.

You can try changing src/SConscript:

-    csim_env.Append (CPPDEFINES = {'SHAPE_DEFAULT': "false"})
+ csim_env.Append (CPPDEFINES = [('SHAPE_DEFAULT', "false")])

Probably needs other changes throughout the file.

Or use the scons-local that's supplied.

scon-local did the trick.

On my 800x480 pixel eeePC display, the 41.kml does not fit the screen. Are there alternatives to try?

Edited: 25 June 2008, 10:25 a.m.

Get http://sense.net/zc/nonpareil/41c.tgz and extract into your nonpareil directory (e.g. /usr/local/lib/nonpareil), then type nonpareil 41cxs. I created a short 35 as well: http://sense.net/zc/nonpareil/35.tgz. Both have been optimized for 640x480 screens. 800x480 is no problem.

Screen shots here: http://sense.net/zc/nonpareil/

You may also want to checkout the patches from here: http://sense.net/zc/x48/. Just get the x48 source and patch with http://sense.net/zc/x48/x48_x11.c.patch. Then you'll have a GX and SX as well. Use Linux C-Kermit to transfer code to/from the emulator. NOTE: I have an x86 x48 binary if you do not want to bother with patching and compiling. Of course you can just use wine and run emu48 if you like.

Edited: 25 June 2008, 12:02 p.m.

Thanks Egan!

Seems to work fine. Now it's time to play. It's a pity that the eeePC does not come with a touch screen. :(

Edited: 26 June 2008, 4:46 a.m.