HP Forums

Full Version: HP 50g won't turn on
You're currently viewing a stripped down version of our content. View the full version with proper formatting.

Forgive me if this is not an appropriate forum for a question like this, but it was all I could find that seemed to be relevant to my situation at all.

I purchased an HP 50g calculator for one of my university classes about a year and a half ago, and used it moderately for the duration of the year. In that time the calculator worked fine, but near the end it started to show low battery alerts, and changing to fresh batteries would not resolve the problem. I ignored it, as the calculator seemed to work fine regardless. Now, I am unable to get the calculator to power on whatsoever, even removing the main and backup batteries and resetting will not allow the thing to turn on.

I'm wondering if anybody would have any suggestions as to what may have caused this problem. I require the calculator for my course, and would be very frustrated to have to buy a new one after only moderate use and a fairly short timespan. I am handy with a soldering iron, so even if it's a known hardware failure I would be able to open the device up and replace some components if needed.

Anybody have any idea what's going on?

Will it power up if USB connected?

Try posting here:


The unit will not power up when hooked up to USB either (it shows "USB device not recognized" on the host system when hooked up this way). Thanks for the link - I will try posting there.

That may be good news. Some sort of transaction may have taken place. If I plug my 50g in to my notebook nothing happens until I power it on. No detection at all.

If Windows does not recognize a device then it will not supply power to the device. Try a USB wall or car charger.

Edited: 13 Feb 2008, 8:51 p.m.

Hmm... I have tried the wall charger and still no go. I think I'm going to have to take the thing apart - but from what I've seen online HP has chosen probably the most painful configuration possible for somebody wishing to open the calculator. Not looking forward to it ;)

This may help:


Well, if anybody's interested I managed to get the calculator working again. I pulled the thing apart (a veritable nightmare, in fact) and after hooking up a standalone power supply to the unit I was able to get it to power on normally. Eventually I managed to get the unit back together and on battery power, although I didn't have to replace any components or such to fix it.

My assumption is either that something had happened to the reset button (it was all gummed up and jammed, and gave me problems when I tried to reassemble the unit, so I pulled it out), or some part of the absolutely excessive shielding in the unit ended up grounding against the PCB for the calculator at some point. Either way, I removed the reset button and the majority of the shielding, reassembled, and the unit is now working as good as new!